CNN Page Layout Problem under 1.5.3 - more missing xpts

RESOLVED FIXED

Status

RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: jmurphy41, Assigned: mark)

Tracking

(Depends on: 1 bug)

unspecified
PowerPC
Mac OS X
Bug Flags:
camino1.5.4 +

Details

(Whiteboard: [camino-1.5.4], URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.9) Gecko/20071025 Camino/1.5.3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.9) Gecko/20071025 Camino/1.5.3

The Local News section of the www.cnn.com page is blank under Camino 1.5.3 The
Local News section displays correclty under Camino 1.5.2

Reproducible: Always

Steps to Reproduce:
1. install Camino 1.5.3
2. enter http://www.cnn.com/
3. confirm that the Local News section is blank
Actual Results:  
Local news section is blank

Expected Results:  
Display the local news, or a dialog box asking for your zip code
(Assignee)

Comment 1

11 years ago
We're missing mozStorageModule: libstoragecomps.dylib/.a.  We should also bundle storage.xpt.
Assignee: nobody → mark
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: CNN Page Layout Problem under 1.5.3 → CNN Page Layout Problem under 1.5.3 - more missing xpts
(Assignee)

Updated

11 years ago
Flags: camino1.5.4?
(Assignee)

Comment 2

11 years ago
Created attachment 287160 [details] [diff] [review]
Include mozStorageModule module from libstoragecomps.(a|dylib) and storage.xpt

This winds up bringing in all of sqlite3, which kind of sucks because it's a lot of code.
Attachment #287160 - Flags: review?(alqahira)
(Assignee)

Comment 3

11 years ago
This change is good for about 300kB in the final dimmidge size.  Not as bad as I feared.
Comment on attachment 287160 [details] [diff] [review]
Include mozStorageModule module from libstoragecomps.(a|dylib) and storage.xpt

r=ardissone

Let Gecko-induced bloating commence!
Attachment #287160 - Flags: review?(alqahira) → review+
(Assignee)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Flags: camino1.5.4? → camino1.5.4+
Resolution: --- → FIXED
Whiteboard: [camino-1.5.4]

Updated

11 years ago
Duplicate of this bug: 405634
You need to log in before you can comment on or make changes to this bug.