camino 1.5.x misreports the "rv" version in the user-agent header

VERIFIED INVALID

Status

VERIFIED INVALID
11 years ago
11 years ago

People

(Reporter: nmehl, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.9) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Camino 1.5.0 and above report only "rv:1.8" in the user-agent header, omitting the minor version details, e.g. 1.8.1.9.  This can cause website which sniff for particular renderer versions, such as gmail, to erroneously exclude Camino.

Reproducible: Always

Steps to Reproduce:
"Make an HTTP GET request"
Actual Results:  
User-agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Expected Results:  
User-agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.9) Gecko/20051111 Firefox/1.5
(Reporter)

Comment 1

11 years ago
Just to avoid confusion: The user-agent string in the bug report says "1.8.1.9" because I've manually tweaked it in about:config.
You're reporting a Firefox 1.5(.0.0) user-agent string here, not a Camino 1.5.x one.  Are you sure you don't mean to report a Firefox bug?

I just made a dummy request to my own server using Camino 1.5.3, and here's the log:

IP_DELETED - - [02/Nov/2007:14:22:34 -0600] "GET /uatest HTTP/1.1" 404 163 "-" "Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.9) Gecko/20071025 Camino/1.5.3"
IP_DELETED - - [02/Nov/2007:14:22:34 -0600] "GET /favicon.ico HTTP/1.1" 200 7782 "-" "Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.9) Gecko/20071025 Camino/1.5.3"
I don't have this problem at all. The user-agent you're reporting (and build you're using) is a Firefox build. Are you using some add-on to change your user-agent string?

Please try with a clean profile or Troubleshoot Camino:

http://pimpmycamino.com/parts/troubleshoot-camino
(Reporter)

Comment 4

11 years ago
Oh good grief.  My apologies: once upon a time I had camitools installed, and this is almost certainly leftover spoor from that.  
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.