outline property on inline-block painted too far outside

RESOLVED FIXED in mozilla1.9beta2

Status

()

defect
P4
normal
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: phiw2, Assigned: roc)

Tracking

({testcase})

Trunk
mozilla1.9beta2
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 +
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

Posted file minimal testcase
The outline property is painted 2px away (outside) of the element.
In the testcase, there is a 2px white gap between the outline and the background-colour. There should be no gap.
Posted image magnified screenshot
OS: Mac OS X → All
Hardware: Macintosh → All
Forgot to note:
The gap is equal to the width of the outline.
outline-width:1px --> 1px gap
outline-width:2px --> 2px gap
etc.
OS: All → Mac OS X
Hardware: All → Macintosh
OS: Mac OS X → All
Hardware: Macintosh → All
Are you sure this is dbaron's fault? You might want to get a regression range on this, because I half-wonder if the border rewrite might be what's actually to blame. Note, I'm not saying that with any information one way or the other, I just think it should be checked.
Oopsie,.. you right. A mix up with test cases. 
It is a recent regression:

Gecko/2007092304 Minefield/3.0a9pre OK
Gecko/2007092404 Minefield/3.0a9pre fails

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-09-23+03%3A00%3A00&maxdate=2007-09-24+03%3A30%3A00&cvsroot=%2Fcvsroot

Bug 96041 ? seems weird.
No longer blocks: inline-block
Blocks: 96041
Flags: blocking1.9?
Assignee: nobody → roc
Posted patch fixSplinter Review
Fairly simple. Only inlines and text frames expect nsLineLayout to call FinishAndStoreOverflow for them; replaced elements and other things to not, they call FinishAndStoreOverflow on themselves, and by calling FinishAndStoreOverflowTwice we include the outline width twice.
Attachment #287615 - Flags: superreview?(dbaron)
Attachment #287615 - Flags: review?(dbaron)
Whiteboard: [needs review]
Flags: blocking1.9? → blocking1.9+
Priority: -- → P4
Comment on attachment 287615 [details] [diff] [review]
fix

r+sr=dbaron
Attachment #287615 - Flags: superreview?(dbaron)
Attachment #287615 - Flags: superreview+
Attachment #287615 - Flags: review?(dbaron)
Attachment #287615 - Flags: review+
Whiteboard: [needs review] → [needs landing]
Checking in layout/generic/nsLineLayout.cpp;
/cvsroot/mozilla/layout/generic/nsLineLayout.cpp,v  <--  nsLineLayout.cpp
new revision: 3.280; previous revision: 3.279
done
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Whiteboard: [needs landing]
Target Milestone: --- → mozilla1.9 M10
Posted patch reftestSplinter Review
I'll check this in when I get a chance
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.