print Page Setup fails with Illegal value... [nsICommandLine::handleFlagWithParam] plus Error: NSPrintSetup is not defined when invoked from 3pane or standalone mail window

RESOLVED FIXED

Status

SeaMonkey
MailNews: Message Display
--
major
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: wsmwk, Assigned: standard8)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
mail window menu fails to bring up Page Setup

Error: [Exception... "'Illegal value' when calling method: [nsICommandLine::handleFlagWithParam]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: file:///C:/Program%20Files/mozilla.org/SM%202.0a%20071022/components/nsBrowserContentHandler.js :: handle :: line 397"  data: no]
Source File: file:///C:/Program%20Files/mozilla.org/SM%202.0a%20071022/components/nsBrowserContentHandler.js
Line: 397

Error: NSPrintSetup is not defined
Source File: chrome://messenger/content/mail3PaneWindowCommands.js
Line: 579

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a9pre) Gecko/2007102203 SeaMonkey/2.0a1pre
(Reporter)

Comment 1

10 years ago
forgot to state, doesn't fail when invoked from browser window.
(Assignee)

Comment 2

10 years ago
Looks like regression from bug 387247. Page Setup in the Message Window is also broken. Patch coming up.
Assignee: mail → bugzilla
Status: UNCONFIRMED → NEW
Depends on: 387247
Ever confirmed: true
OS: Windows Vista → All
QA Contact: mail
Hardware: PC → All
(Assignee)

Comment 3

10 years ago
Created attachment 287251 [details] [diff] [review]
The fix

These looked fine when I viewed them in emacs :/
Attachment #287251 - Flags: review?(neil)
(Assignee)

Comment 4

10 years ago
(In reply to comment #3)
> Created an attachment (id=287251) [details]
> The fix
> 
> These looked fine when I viewed them in emacs :/
(the indentation, that is)

Comment 5

10 years ago
Yeah, looks good to me apart from the indentation.

Comment 6

10 years ago
Comment on attachment 287251 [details] [diff] [review]
The fix

> 			case "cmd_printSetup":
>-			  NSPrintSetup();
>+                PrintUtils.showPageSetup();
> 			  return;
While you're there you might as well fix the tabs on the other two relevant lines too (I'm not one for random whitespace fixup but I figure these three lines are sufficiently related to merit it, as per the other hunk).
Attachment #287251 - Flags: review?(neil) → review+
(Assignee)

Comment 7

10 years ago
Patch checked in to trunk with whitespace fixed.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.