DNS problem with Firefox 2.0.0.9 after updating from 2.0.0.8: Firefox queries NBNS (NetBIOS) instead of DNS

RESOLVED INCOMPLETE

Status

()

Core
Networking
--
major
RESOLVED INCOMPLETE
11 years ago
2 years ago

People

(Reporter: guzza, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007110304 Minefield/3.0a9pre
Build Identifier: http://www.mozilla.com/en-US/products/download.html?product=firefox-2.0.0.9&os=win&lang=en-US

After I received the message that my Firefox has updated to 2.0.0.9 ( mine was 2.0.0.8) and I need to restart it to finish the update I chose to restart later. Later when I restarted the install finished with no problems. Upon trying to open a web page it didnt work .. to cut it short I used Wireshark to sniff packets because Opera and everything other that internet related worked and saw that Firefox is trying to get the name query for ex. google.com over the NBNS(NetBIOS) protocol while every other program was using the DNS protocol and the router that I'm connected to isn't responding to that query.

I uninstalled it and reinstalled it .. same thing... didn't work

Then I uninstalled it and removed all application data from the doc and setts of windows just in case ...same thing... didn't work

Then I checked my Anti-vir if its messing with it .. nothing .. closed and uninstalled the antivir and reainstalled firefox...same thing... didn't work

Then I thought that an install from VMWare workstation is messing with it so uninstalled that too ..same thing... didn't work

Finally I downloaded the latest night build (because I couldn't find 2.0.0.8 version nowhere :S ) and It works like a charm and sends DNS queries and not NBNS queries ...

so ... :S


Reproducible: Always

Steps to Reproduce:
everything told in the details tab
Actual Results:  
everything told in the details tab

Expected Results:  
everything told in the details tab
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0 Branch

Updated

11 years ago
Summary: DNS problem with Firefox 2.0.0.9 after updating from 2.0.0.8 → DNS problem with Firefox 2.0.0.9 after updating from 2.0.0.8: Firefox queries NBNS (NetBIOS) instead of DNS

Comment 1

11 years ago
Similar problems have been reported in the past: bug 244600, bug 266647.  We never figured out why it happened for those users.

Are you using a VPN?
(Reporter)

Comment 2

11 years ago
I'm not using VPN but I'm still suspecting that VMWare Workstation install messed up Firefox because it installed so many custom drivers trying to replace normal OS drivers and maybe that confused Firefox. I also have Kaspersky installed but the Firewall has been shut down a long time ago but that still maybe the problem. The Windows install is relatively fresh so can't be any old problems or mods to the system. I checked the system and there is nothing else that could be messing with Firefox.

Comment 3

10 years ago
I am encountering exactly the same problem. Version:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

This is WinXP. There is no VPN or VMWare involved. It worked fine yesterday. I suppose an automatic update happend, but I am not sure about that.

Comment 4

9 years ago
see this with 3.1beta? http://www.mozilla.com/en-US/firefox/all-beta.html

(In reply to comment #1)
> Similar problems have been reported in the past: bug 244600, bug 266647.  We
> never figured out why it happened for those users.

bug 244600 was closed invalid by benc@meer.net 2008-07-09 "isn't this that IPv6+DNS problem?"

bug 266647 expired
Component: General → Networking
Product: Firefox → Core
QA Contact: general → networking
Version: 2.0 Branch → 1.8 Branch
Is this still a problem ?

Comment 6

3 years ago
Maybe this is similar with https://bugzilla.mozilla.org/show_bug.cgi?id=1174249
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.