Text/plain Subject in Cyrillic without encoding string are incorrectly encoded

RESOLVED INVALID

Status

Thunderbird
General
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: arnymars, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Opera/9.50 (Windows 98; U; en)
Build Identifier: 2.0.0.6 (20070728)

Text/plain Subject lines in Cyrillic without encoding string in Subject line are not readable - while the same message Body containing its own Encoding String is readable. Subjects are applied either default Cyrillic encoding, or message Body encoding instead of being shown "as is" without applying any encoding.

Reproducible: Always

Steps to Reproduce:
1. Every e-mail in Cyrillic, where Subject line does not contain encoding string, but message Body does contain encoding string.
2.
3.


Expected Results:  
Show Subject Text "as is" without applying any encoding, if the encoding string in Subject Line is missing.
(Reporter)

Comment 1

11 years ago
Bug 401204 describes another error in decoding Subject lines. Apparently, subject line decoding requires an independent approach from message body decoding. Many Mail Servers send messages in Cyrillic without encoding string in subject line, but with encoding string in the message body. It's wrong to simply apply message body encoding to same message subject line. Leave subject line as is. Do not suggest users to require originating e-mail server Admins to comply with standards - it's not a realistic solution for an average e-mail recipient. Unfortunate reality is - web browsers and e-mail clients must account for most typical errors on webpages and in e-mails.
(Reporter)

Comment 2

11 years ago
See Thunderbird Forum Post: http://forums.mozillazine.org/viewtopic.php?t=590385&highlight=
(Reporter)

Comment 3

11 years ago
You can learn more about people suffering from this bug from the Mozilla RU Forum Post: http://forum.mozilla-russia.org/viewtopic.php?id=14499&p=1
Translate in to English with Google Translate to enjoy.
(Reporter)

Comment 4

11 years ago
Similar error - Message Subject is unreadable - occurs, when Subject has its own encoding string, and the Subject text is encoded, but the Subject encoding string does not correspond to actual Subject text encoding. It shows that due to variety of Cyrillic Mail Clients ans Server Robots in use, and concurrent use of several Cyrillic Charsets, Thunderbird should perform analysis of the Subject text encoding regardless of the Subject encoding string presence. Such analysis (pretty easy to differentiate the text by its string character sequence) will seriously improve program usability. NO ADVICE TO FIX EVERYTHING AROUND THUNDERBIRD in order to avoid fixing it is realistic & acceptable.
(Reporter)

Comment 5

11 years ago
Pls understand that due to historical use of several different Cyrillic Charsets, Mail Servers in Russia are facing tremendous objections from the public in bringing Subject Encoding to standards, as it makes the Subjects of all previous mail Archive unreadable & unsearchable for most users.

Comment 6

11 years ago
> Text/plain Subject lines in Cyrillic without encoding string in Subject line
> are not readable - while the same message Body containing its own Encoding
> String is readable.

That is correct, not a bug.
Headers have no charset, because there's no way to specify a charset for them. You can't specify the charset in the headers, because you need the charset to decode them, and the charset can completely alter the byte interpretation, not all carsets are ASCII-compatible.

Thus, headers must be in ASCII (or UTF8?). If you want a cyrillic subject, you need to put the encoding in the subject header.

It may work nevertheless, that Mail reparses the headers etc. in some cases, but these are hacks to deal with broken/buggy sender software and cannot be counted on.

INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.