Last Comment Bug 402439 - Clipboard is emptied on application exit
: Clipboard is emptied on application exit
Status: VERIFIED FIXED
: dataloss, regression, relnote
Product: Core
Classification: Components
Component: Widget: Win32 (show other bugs)
: Trunk
: x86 Windows 2000
: P2 major with 1 vote (vote)
: ---
Assigned To: Ere Maijala (slow)
:
: Jim Mathies [:jimm]
Mentors:
: 404800 (view as bug list)
Depends on: 403724
Blocks: 386286
  Show dependency treegraph
 
Reported: 2007-11-04 07:31 PST by Serge Gautherie (:sgautherie)
Modified: 2009-10-24 20:46 PDT (History)
14 users (show)
mbeltzner: blocking1.9+
bugzillamozillaorg_serge_20140323: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (3.99 KB, patch)
2007-11-08 09:51 PST, Ere Maijala (slow)
neil: review+
roc: superreview+
mtschrep: approval1.9+
Details | Diff | Splinter Review

Description Serge Gautherie (:sgautherie) 2007-11-04 07:31:25 PST
Regressed between
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a9pre) Gecko/2007103103 Minefield/3.0a9pre] (nightly) (W2Ksp4)
and
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a9pre) Gecko/2007110103 Minefield/3.0a9pre] (nightly) (W2Ksp4)

Confirmed by
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a9pre) Gecko/2007103102 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)
and
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a9pre) Gecko/2007110103 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

My steps:
1. Start browser application.
2. Load <about:>.
3. Copy the build id "line".
4. Paste it in another app: works :-)
5. Exit browser application.
6. Paste it in another app: no more data :-(

<http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=MozillaTinderboxAll&branch=HEAD&branchtype=match&sortby=Date&hours=2&date=explicit&mindate=2007-10-31+03&maxdate=2007-11-01+04+&cvsroot=%2Fcvsroot>
My best guess would be bug 386286.
Comment 1 Mike Beltzner [:beltzner, not reading bugmail] 2007-11-05 10:53:38 PST
Blocking, but not blocking beta. Adding relnote ...
Comment 2 Ere Maijala (slow) 2007-11-08 09:48:38 PST
Taking.
Comment 3 Ere Maijala (slow) 2007-11-08 09:51:40 PST
Created attachment 287856 [details] [diff] [review]
Patch

This should fix it. The problem was that OleUninitialize was called before the observer in nsClipboard tried to call OleFlushClipboard. I removed the observed and moved OleFlushClipboard right before OleUninitialize. The comment changes are just removed CR's.
Comment 4 Ere Maijala (slow) 2007-11-08 09:54:42 PST
And the CloseClipboard call in nsClipboard was superfluous.
Comment 5 Serge Gautherie (:sgautherie) 2007-11-08 11:18:40 PST
(Had a look at MSDN for both functions: the fix looks perfect ;-))
Comment 6 neil@parkwaycc.co.uk 2007-11-08 11:33:20 PST
Comment on attachment 287856 [details] [diff] [review]
Patch

>+NS_IMPL_ISUPPORTS1(nsClipboard, nsBaseClipboard)

>+  NS_DECL_ISUPPORTS

You shouldn't need these, nsBaseClipboard already provides them.
(They were there before to resolve the ambiguous nsISupports cast.)
Comment 7 Ere Maijala (slow) 2007-11-08 11:35:32 PST
Comment on attachment 287856 [details] [diff] [review]
Patch

Ok, I'll remove them before checking in.
Comment 8 Ryan VanderMeulen [:RyanVM] 2007-11-10 05:38:44 PST
Ere, jst-review takes exception to your patch as well.
http://beaufour.dk/jst-review/
Comment 9 neil@parkwaycc.co.uk 2007-11-10 06:32:13 PST
(In reply to comment #8)
>Ere, jst-review takes exception to your patch as well.
>http://beaufour.dk/jst-review/
That's a bug in jst-review, not in the patch.
Comment 10 Ryan VanderMeulen [:RyanVM] 2007-11-10 06:57:26 PST
Not the complaint about Windows line endings...
Comment 11 Ere Maijala (slow) 2007-11-10 07:04:03 PST
?? The patch _removes_ a couple of Windows line endigns and I can't see jst-review complaining about that.
Comment 12 Ryan VanderMeulen [:RyanVM] 2007-11-10 07:05:38 PST
OK, nevermind me then :). Sorry for the spam.
Comment 13 Reed Loden [:reed] (use needinfo?) 2007-11-13 08:27:16 PST
Ere, think you could commit this soon? If you don't have time, just let me know, and I can check it in for you.
Comment 14 Ere Maijala (slow) 2007-11-13 09:36:17 PST
Fix checked in.
Comment 15 Serge Gautherie (:sgautherie) 2007-11-14 05:41:04 PST
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b2pre) Gecko/2007111403 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

V.Fixed.
Comment 16 Mats Palmgren (:mats) 2007-11-21 10:00:30 PST
*** Bug 404800 has been marked as a duplicate of this bug. ***
Comment 17 Mats Palmgren (:mats) 2007-11-21 10:04:24 PST
FYI, this bug isn't listed in Beta 1 rel notes yet:
http://www.mozilla.com/en-US/firefox/3.0b1/releasenotes/
Comment 18 Ere Maijala (slow) 2007-12-02 01:51:59 PST
(In reply to comment #17)
> FYI, this bug isn't listed in Beta 1 rel notes yet:
> http://www.mozilla.com/en-US/firefox/3.0b1/releasenotes/

Is there still a reason to relnote something as this is fixed?

Comment 19 Ria Klaassen (not reading all bugmail) 2009-10-20 09:09:19 PDT
This may be a fixed bug but I see it every day.
Comment 20 Serge Gautherie (:sgautherie) 2009-10-24 20:46:16 PDT
(In reply to comment #19)
> This may be a fixed bug but I see it every day.

This bug was (reported) fixed 2 years ago.
Please file a new bug, with details.

Note You need to log in before you can comment on or make changes to this bug.