Firefox.exe process in Task Manager, restarts itself when killed

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: ahbennett, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

Since installing the last release of Firefox, I have been seeing an extra firefox process in Task Manager that uses 3.4kb of RAM. I have tried terminating the process and tree, reinstalling, etc. This process still comes up no matter what I do. It interferes with updates, causing them to fail due to running process, so I must constantly kill it manually when updating. v2.0.0.9 has not stopped this issue. When initiated, the process hits the DNS server and stays active until the computer is shut down. Again, when terminated, it auto-starts again.
I would appreciate it if you would at least email me an option to stop this troublesome issue if not fix it altogether. (Comodo is convinced it's a virus or malware/spyware, though everything I've run thus far has refuted this claim.)


Reproducible: Always

Steps to Reproduce:
1.Restart Computer
2.Kill Process
3.
Actual Results:  
As stated above, the annoying process restarts.

Expected Results:  
How the hell should I know?


Ug, think it's all in the general description. I use no themes, no background, screensaver. Only Comodo Firewall Pro and WinRam Turbo. Oh, also F-Prot Antivirus.

Comment 1

11 years ago
Sure sounds like malware to me.  Does Task Manager give you a way to determine the full path of the program so you can differentiate two firefox.exes on your machine?

Updated

11 years ago
Summary: Firefox.exe process in Task Manager → Firefox.exe process in Task Manager, restarts itself when killed

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

11 years ago
The above link to the Ivy trojan information was successful in removing my problem, though everything I tried failed to identify the trojan, including the new Comodo BOClean 4.25. Thanks much J.R. for that link and subsequent eMail. :)
Resolution: INVALID → FIXED

Comment 4

11 years ago
This bug is NOT FIXED.  FIXED requires that there be some identifiable change to the product's code which resolves the issue.
Resolution: FIXED → WORKSFORME
(Reporter)

Comment 5

11 years ago
(In reply to comment #4)
> This bug is NOT FIXED.  FIXED requires that there be some identifiable change
> to the product's code which resolves the issue.
> 

Perhaps you missed the previous post... The problem is not a bug with Mozilla, it's a Trojan virus, which cannot be corrected by any code change, thus the problem is FIXED.
(Reporter)

Comment 6

11 years ago
(In reply to comment #4)
> This bug is NOT FIXED.  FIXED requires that there be some identifiable change
> to the product's code which resolves the issue.
> 

Perhaps you missed the previous post... The problem is not a bug with Mozilla, it's a Trojan virus, which cannot be corrected by any code change, thus the problem is FIXED.
Resolution: WORKSFORME → FIXED
hey anthony, its works for me, because the "Fixed" Status mean in Bugzilla that a code change in a Mozilla Product (like Firefox) was done to fix this problem.

For other problems like in your case with a Trojan its in Bugzilla "works for me", because the problem was resolved without a change in Firefox.
Resolution: FIXED → WORKSFORME
(Reporter)

Comment 8

11 years ago
UG! There is no way to correct the code in this case in order to resolve the issue, so it makes no sense to post it as anything other than FIXED.

Have it your way though, maybe an admin with a brain will have sense enough to change it to something reasonable and lock the damn thread.
(Assignee)

Updated

11 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.