IMAP folder scrolls to top while auto refreshing from folder switch

RESOLVED DUPLICATE of bug 394355

Status

Thunderbird
Mail Window Front End
--
trivial
RESOLVED DUPLICATE of bug 394355
11 years ago
11 years ago

People

(Reporter: Rod Vagg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: 2.0.0.6 (20070728)

I prefer to see my mail folders with the newest at the bottom of the list. When I click on a folder in an IMAP account it waits until it has refreshed the message list from the server before automatically scrolling to the bottom where I had it last.
Ideally, the scroll would happen before the refresh so I could see the new messages that it already knows about and I can get on with things instead of having to wait for TB to refresh (or manually scrolling down while the refresh is happening).

Reproducible: Always

Steps to Reproduce:
1. Create IMAP account with more than 1 page worth of messages
2. Sort with newest messages last
3. Click to view INBOX (or other folder)

Comment 1

11 years ago
see this also in trunk.

I think to see this, folder in step 3 must have NEW messages
Severity: normal → trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: IMAP folder scrolls to top while auto refreshing → IMAP folder scrolls to top while auto refreshing from folder switch

Comment 2

11 years ago
in fact, a dupe
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 394355
You need to log in before you can comment on or make changes to this bug.