Build failure in nsCookieService if PR_LOGGING is not defined

RESOLVED DUPLICATE of bug 402395

Status

()

RESOLVED DUPLICATE of bug 402395
11 years ago
11 years ago

People

(Reporter: masayuki, Assigned: masayuki)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 287375 [details] [diff] [review]
fix

If PR_LOGGING is not defined, there is an empty line before ';':
>   nsresult rv = InitDB();
>   if (NS_FAILED(rv))
>     COOKIE_LOGSTRING(PR_LOG_WARNING, ("Init(): InitDB() gave error %x", rv));

By this warning, I cannot build with VC2005 and cygwin.

Should use PR_BEGIN_MACRO and PR_END_MACRO.
Flags: blocking1.9?
Attachment #287375 - Flags: superreview?(mconnor)
Attachment #287375 - Flags: review?(mconnor)
Summary: Build failure in nsCookieService if #PR_LOGGING is not defined → Build failure in nsCookieService if PR_LOGGING is not defined
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 402395
Attachment #287375 - Flags: superreview?(mconnor)
Attachment #287375 - Flags: review?(mconnor)
No longer blocks: 401998
Flags: blocking1.9?
Target Milestone: mozilla1.9 M9 → ---
You need to log in before you can comment on or make changes to this bug.