Text in tables and Divs are incorrect displayed

RESOLVED FIXED

Status

()

--
major
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: tchung, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9a9pre) Gecko/2007110518 Minefield/3.0a9pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9a9pre) Gecko/2007110518 Minefield/3.0a9pre

The Text on websites using tables or divs are horribly displayed.  See the attachments.

Please move this to Core layout if thats where it belongs.

Reproducible: Always

Steps to Reproduce:
1. Download latest minefield nightly
2. Go to any site with tables or divs
3. Verify the text is garbled and incorrectly displayed.

See the various screenshots.  I think this is a regression between 2007-11-04 and 2007-11-05 nightly?
Actual Results:  
Cluttered display of text, incorrect formatting.  

Expected Results:  
Correctly displayed text.
(Reporter)

Comment 1

11 years ago
Created attachment 287501 [details]
Screenshot 1
(Reporter)

Comment 2

11 years ago
Created attachment 287502 [details]
Screenshot 2
(Reporter)

Comment 3

11 years ago
Created attachment 287503 [details]
Screenshot 3
(Reporter)

Comment 4

11 years ago
Created attachment 287504 [details]
Screenshot 4
(Reporter)

Updated

11 years ago
Flags: blocking-firefox3?

Comment 5

11 years ago
Works fine here
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O 10.4; en-US; rv:1.9a9pre) Gecko/2007110523 Minefield/3.0a9pre
(Reporter)

Comment 6

11 years ago
It seems to happen every time on build:

 Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9a9pre) Gecko/2007110518 Minefield/3.0a9pre ID:2007110518 [cairo]

I've tried this with several profiles.   hmm, perhaps something changed with in the hourly update between 2007110518 and 2007110518?

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&date=hours&hours=2&mindate=2007110518&maxdate=2007110523&cvsroot=%2Fcvsroot
(Reporter)

Comment 7

11 years ago
correction: between 2007110518 and 2007110523?

Comment 8

11 years ago
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-11-05+15%3A00%3A00&maxdate=2007-11-05+23%3A00%3A00&cvsroot=%2Fcvsroot

Some people were playing with optimization flags for Intel Mac (Dolske and others). Maybe that gave strange results ?
I'm on PPC and my home-made Camino build (checkout time around 15:00 PST), the official Camino trunk builds (from tinderbox) and Minefield all work correctly for this issue.
cc'ing dolske and sayrer:

Did you guys notice any layout regressions from when you were playing around with the compilation flags? Downloading the build referenced by Tony, above, and loading a large bugzilla query (say: http://tinyurl.com/2379h3) I see the behaviour, but can't repeat in a nightly.

Minusing for now, if it turns out to be repeatable, please renominate.
Flags: blocking-firefox3? → blocking-firefox3-
Component: General → Layout
Flags: blocking-firefox3-
Product: Firefox → Core
QA Contact: general → layout
The changes that caused this (optimization flag expirements) were all backed out, as far as I know. INVALID, I guess.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
Doesn't that mean FIXED?  I mean, I don't mean to offer offense.
Sure, whatever.
Resolution: INVALID → FIXED
Duplicate of this bug: 402644
You need to log in before you can comment on or make changes to this bug.