URLs are frequently truncated at the beginning in autocomplete results

RESOLVED INVALID

Status

()

Firefox
Address Bar
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
Created attachment 287513 [details]
screenshot 1

Lots of URLs are truncated at the beginning in autocomplete results, even though the matching part of the autocomplete result is also near the beginning.  I think this is a regression from the recent patch in bug 399664.
(Reporter)

Comment 1

11 years ago
Created attachment 287514 [details]
screenshot 2
this is related to bug #399664 (notice the ellipsis before the truncated urls)

I was going to write that this is sort of by design (as we want to ensure the emphasized / matching part is visible), but perhaps what we should do is try put the matching part in the middle of the scrollbox, which should be doable.

thoughts?
OS: Mac OS X → All
Hardware: PC → All
No longer blocks: 399664
Depends on: 399664
Blocks: 399664
No longer depends on: 399664
Created attachment 287521 [details]
another screen shot

notice how most of bugzilla results are correct, but the two at the bottom are cropped incorrectly.

something must be going on with _setUpDescription() in #399664
I think we should always display the domain, followed by an ellipse (if necessary), and then the matching text.  So for instance:

http://subdomain.domain.com...matchingText/folder/fol..

This means that some matching results will not be sown if the domain is really long, but it is also important to try to mitigate phishing.
when bug #399664 was backed out, this became invalid.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.