If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cancel download during xpcom.xpi download (>80%) continues with extraction

VERIFIED WONTFIX

Status

SeaMonkey
Installer
P1
normal
VERIFIED WONTFIX
18 years ago
13 years ago

People

(Reporter: Grace Bush, Assigned: Samir Gehani)

Tracking

Trunk
Future
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-])

(Reporter)

Description

18 years ago
Steps to reproduce:
1. Start MacNetscapeInstaller
2. Choose typical/default location etc
3. During download- allow xpcom.xpi to download >80%, press cancel

Actual behavior: file continues to download and extract
Expected behavior: end of download
(Assignee)

Comment 1

18 years ago
This is will be addressed when bug 34014 is being addressed.  We are currently 
detecting SmartDownload errors and should stop if we get one.  Apparently, 
SmartDownload is not passing back any error code in the event of cancellation.  
Needs debugging to confirm.  We can workaround this from our end.
Status: NEW → ASSIGNED
Target Milestone: --- → M17
(Assignee)

Updated

18 years ago
Keywords: nsbeta2

Comment 2

18 years ago
Putting on [nsbeta2-] radar.  
Whiteboard: [nsbeta2-]
These won't make 6.0 for sure
Target Milestone: M17 → Future

Comment 4

17 years ago
updating mac mozilla installer QA contact to me
QA Contact: gbush → asa
(Assignee)

Updated

17 years ago
Priority: P3 → P1
(Assignee)

Comment 5

17 years ago
Irrelevant since SmartDownload has been replaced with libxpnet.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 6

17 years ago
vfy
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.