SOCKS5 'host unreachable' shows a 'The Connection has Timed out'

RESOLVED DUPLICATE of bug 129502

Status

()

Core
Networking
--
minor
RESOLVED DUPLICATE of bug 129502
11 years ago
11 years ago

People

(Reporter: Dan Merillat, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.0.10) Gecko/20070217 Iceape/1.0.8 (Debian-1.0.8-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.6) Gecko/20070723 Iceweasel/2.0.0.6 (Debian-2.0.0.6-1)

In determining why I was getting near-instant 'connection timed out' messages when using SOCKS5, I ran strace on my proxy server.

The return is:
sendto(5, "\5\4\0\1\0\0\0\0\0\0", 10, 0, NULL, 0) = 10

Which RFC1928 translates to:
Version 5, Host Unteachable, no bind address.

I would wager most of the bugs filed against "too-short network timeouts for proxies" are due to this.  

Reproducible: Always

Steps to Reproduce:
1) Configure a socks5 proxy.
2) Attempt to connecto to a server that would cause an 'unreachable' error

Actual Results:  
The connection has timed out

The server at XXXXX is taking too long to respond.

    *   The site could be temporarily unavailable or too busy. Try again in a few moments.

    *   If you are unable to load any pages, check your computer's network
          connection.

    *   If your computer or network is protected by a firewall or proxy, make sure that Iceweasel is permitted to access the Web.

Expected Results:  
An error message about "Host unreachable"

It's trivial, but google searches for 'The connection has timed out' harp on changing the connect timeout because it's too fast.  If the correct error message showed up, it would reduce confusion.   This appears to be specific to SOCKS protocol connections.
Component: General → Networking
Product: Firefox → Core
QA Contact: general → networking
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 129502
You need to log in before you can comment on or make changes to this bug.