cannot turn on empty words on find specific bugs page

RESOLVED WORKSFORME

Status

()

Bugzilla
Query/Bug List
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Olga Jerebtsova, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: 3.0.4

in v.3.0.2, one cannot perform searches on Find Specific Bug page without entering something in Words field. I tried to change specific_search_allow_empty_words setting on and off, but it still required something to be entered in Words field.

Reproducible: Always

Steps to Reproduce:
1.go to Search
2. click on Find Specific Bug
3. click on Search
 popup message shows with specific_search_allow_empty_words set on and off
Actual Results:  
pop up message "The Words field cannot be empty..." shows with specific_search_allow_empty_words set on and off

Expected Results:  
The search should allow empty string in Words field with specific_search_allow_empty_words setting truned on

Comment 1

11 years ago
I cannot reproduce neither on the 3.0 branch nor on tip. Be sure you reloaded your page after having turned on the parameter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Updated

11 years ago
Duplicate of this bug: 404338
(Reporter)

Updated

11 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 3

11 years ago
Make sure template/en/default/search/search-specific.html.tmpl contains these lines:

      [% IF Param('specific_search_allow_empty_words') %]
        <input type="submit" id="search" value="Search">
      [% ELSE %]
        <input type="submit" id="search" value="Search"
             onclick="if (this.form.content.value == '')
                      {alert('The Words field cannot be empty. You have to ' +
                             'enter at least one word in your search criteria.');
                       return false;} return true;">
      [% END %]

If that's the case, the onclick JS event should not appear in your HTML page.
OS: Linux → All
Version: unspecified → 3.0.2
(Reporter)

Comment 4

11 years ago
Yes, the code is present.
I tried to comment out 'alert' part from else clause, but got big red error message saying that I cannot perform search with empty words.

Comment 5

11 years ago
Make sure you have this line in data/params:

'specific_search_allow_empty_words' => '1'

If the value is 0, then the error is expected. It *must* be 1.
(Reporter)

Comment 6

11 years ago
it is currently set to 'specific_search_allow_empty_words' => '1'.

Comment 7

11 years ago
Sorry, but something must be wrong with your installation or browser. Based on your information, this must work. Try asking in the support list, see http://www.bugzilla.org/support/. From the dev point of view, this bug is WFM, so marking as such again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.