Extensions and Themes cannot be marked higher than current versions, breaking them when users install betas

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
11 years ago
3 years ago

People

(Reporter: abillings, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
Neither themes or extensions can be marked as compatible with a higher version than the current shipped version of Firefox and Thunderbird. This means that when a new milestone build or a Beta (!) is released, every user gets to experience all of their extensions and themes disabling themselves and also being unable to install any more. Currently, the only fix is for all of the extension and theme creators to go update their themes and extensions *after* a milestone or Beta comes out. We should have a mechanism where they can specify a compatibility higher than the currently shipped version (like "3.0*") so that their users don't have the wonderful beta experience of all of their extensions and themes breaking or failing to install. That is a horrible experience.
Duping, feel free to reopen if you think that this is wrong. There are still changes landing, so allowing 3.0.* during development will probably cause broken add-ons marked as compatible in the add-ons manager.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
OS: Mac OS X → All
Hardware: PC → All
Resolution: --- → DUPLICATE
Version: unspecified → 3.0
Duplicate of bug: 369742
(Reporter)

Comment 2

11 years ago
This isn't a dupe. The other bug covers other, specific, issues. 

I think we should allow people to say that their extension is compatible with a higher version that what is currently shipped. Otherwise, every time we ship, every user who downloads it immediately has their extensions disabled. Not a good experience.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

11 years ago
Oh, and if something breaks in an extension during a beta? Well:

1) It's a beta. If something breaks, they shouldn't be surprised. Wait until the release if you want perfection.

2) I'd rather have one extension break than have ALL of my extensions disabled *for* me simply because I installed the new build when it comes out.

Realistically, extension authors should be able to say "I will take the risk as I think my extension won't break" and flag their extension as "3.0*" or somehow higher than what has already shipped.
Al, as there is a smaller minority that cares about Beta compatibility, can't the Firefox testing/beta user simply set extensions.checkCompatibility to false and then they are ready to work? This is a better solution that to have every add-on claim forward compatibility because once you do, you'll never know what the add-on is compatible with (on the max side).

Marking as wontfix 
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → WONTFIX
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.