Closed Bug 402999 Opened 12 years ago Closed 12 years ago

Installer defaults to official install directory for beta releases

Categories

(Firefox :: Installer, defect, P1)

x86
Windows Vista
defect

Tracking

()

VERIFIED FIXED
Firefox 3 beta1

People

(Reporter: rstrong, Assigned: rstrong)

Details

(Keywords: regression)

Attachments

(3 files, 1 obsolete file)

When we use official branding the install directory defaults to an official release's install directory if present. This is fallout from bug 361402.
Attached patch patch (obsolete) — Splinter Review
Attachment #287811 - Flags: review?(sspitzer)
Comment on attachment 287811 [details] [diff] [review]
patch

>+# Add !define BETA_RELEASE for Beta releases to prevent using the same
>+# installation directory as official releases.
>+!define BETA_RELEASE

Shouldn't this be commented out by default and only changed on the RELBRANCH, such as we did for bug 402605?
Yep, as the comment states the define is only for Beta releases. If for whatever reason there is a respin of M9 it would land as is on that branch and it would land on the trunk without !define BETA_RELEASE or with !define BETA_RELEASE commented out.
Why shouldn't we install into the official directory? The beta releases are stable enough for everyday browsing, and we really want to get testing of the paveover install scenario.
Previous beta releases have shown that some people will want to go back to an official release due to extension compatibility and I am sure other reasons.
Comment on attachment 287811 [details] [diff] [review]
patch

r=sspitzer,

1)

per robert, we should cvs remove this:

mozilla/browser/branding/unofficial/branding.nsi

2) to both of these files, 

mozilla/other-licenses/branding/firefox/branding.nsi
mozilla/browser/branding/unofficial/branding.nsi

robert agrees that we should:

a) remove these lines:

 49 # Percentage of new "Standard" installs to enable talkback for
 50 !define RandomPercent         "10"

b)

Put these lines:

+# Add !define BETA_RELEASE for Beta releases to prevent using the same
+# installation directory as official releases.
+!define BETA_RELEASE

Near:

!define BrandFullName         "Mozilla Firefox"

As that's what we modify for beta.

3)

If we have some sort of beta checklist, we should explicitly add this step (define BETA_RELEASE and change BrandFullName to include the word " Beta <x>") to that list.
Attachment #287811 - Flags: review?(sspitzer) → review+
(In reply to comment #6)
> 1)
> 
> per robert, we should cvs remove this:
> 
> mozilla/browser/branding/unofficial/branding.nsi
> 
> 2) to both of these files, 
> 
> mozilla/other-licenses/branding/firefox/branding.nsi
> mozilla/browser/branding/unofficial/branding.nsi
...

Huh? That doesn't make sense. Why would mozilla/browser/branding/unofficial/branding.nsi be removed? Don't we use it for Gran Paradiso builds?
It appears that it is not "working for now" per the checkin comment from 2006-11-21... if it is still not working it should be removed and if the functionality is still desired it should be re-added when a patch is ready that adds the functionality.
http://bonsai.mozilla.org/cvslog.cgi?file=mozilla/browser/branding/unofficial/branding.nsi&rev=HEAD&mark=1.2

A bug describing what functionality and how it will provide this functionality would also be a good thing IMO.
I changed the comments and the name of the define to be more explicit.

Filed bug 403118 to figure out what's up with the additional branding.nsi file
Attachment #287811 - Attachment is obsolete: true
Attachment #287928 - Flags: review+
Comment on attachment 287928 [details] [diff] [review]
patch w/ comments addressed

Drivers, this makes it so we don't have to default to an existing install for a branch nightly, trunk nightly, or official release. Since we use official for beta releases the beta installer defaults to the install directory of any official release if one is present.
Attachment #287928 - Flags: approval1.9?
rob: when i start to verify this bug on the beta 1, are there specific test scenarios i can do to verify this bug ? 
On a system with only one official release installed (e.g. 2.0.0.9) install Beta 1 and prior to clicking install note the install directory. Without this patch it would be the directory the official release is installed into. With this patch it would be "Mozilla Firefox 3 Beta 1" as long as Beta 1 isn't already installed.
Landed on GECKO190_20071106_RELBRANCH for Firefox 3 Beta 1

Checking in mozilla/toolkit/mozapps/installer/windows/nsis/common.nsh;
/cvsroot/mozilla/toolkit/mozapps/installer/windows/nsis/common.nsh,v  <--  common.nsh
new revision: 1.32.2.1; previous revision: 1.32
done
Checking in mozilla/browser/installer/windows/nsis/branding.nsi;
/cvsroot/mozilla/browser/installer/windows/nsis/branding.nsi,v  <--  branding.nsi
new revision: 1.7.6.1; previous revision: 1.7
done
Checking in mozilla/other-licenses/branding/firefox/branding.nsi;
/cvsroot/mozilla/other-licenses/branding/firefox/branding.nsi,v  <--  branding.nsi
new revision: 1.8.2.2; previous revision: 1.8.2.1
done

I'll land the patch on the trunk after the tree reopens
Priority: -- → P1
Target Milestone: --- → Firefox 3 M9
something similar needs to be done on the 2.0.0.x branch.  

If you start with Mozilla Firefox 3 beta 1, then install 2.0.0.9, some Frankenfox thing is created that can't be shocked to life.  There is no "Mozilla Firefox" application directory only the initial Mozilla Firefox 3 beta 1 directory.  a desktop icon for both exist, but neither launches any version of Fx. Attempt to launch Fx from the firefox.exe also fails.
That is at least in part due to crashreporter not being removed on a pave over install of a Firefox 3 install. This bug is just about not installing the beta over the top of Firefox 2.0.0.x and if you already have Firefox 2.0.0.x installed and install the beta a second attempt to install Firefox 2.0.0.x will not attempt to install into the directory the beta installed into.

To resolve this, uninstall and then re-install.
Attachment #287928 - Flags: approval1.9? → approval1.9+
Checked in to trunk

Checking in mozilla/toolkit/mozapps/installer/windows/nsis/common.nsh;
/cvsroot/mozilla/toolkit/mozapps/installer/windows/nsis/common.nsh,v  <--  common.nsh
new revision: 1.33; previous revision: 1.32
done
Checking in mozilla/browser/branding/unofficial/branding.nsi;
/cvsroot/mozilla/browser/branding/unofficial/branding.nsi,v  <--  branding.nsi
new revision: 1.3; previous revision: 1.2
done
Checking in mozilla/browser/installer/windows/nsis/branding.nsi;
/cvsroot/mozilla/browser/installer/windows/nsis/branding.nsi,v  <--  branding.nsi
new revision: 1.8; previous revision: 1.7
done
Checking in mozilla/other-licenses/branding/firefox/branding.nsi;
/cvsroot/mozilla/other-licenses/branding/firefox/branding.nsi,v  <--  branding.nsi
new revision: 1.9; previous revision: 1.8
done
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
verified fixed using the steps to reproduce from comment #2 and  Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1

-> Verified fixed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.