An error occurred while sending mail. The mail server responded: Sender address and login must be equal.. Please verify that your email address is correct in your Mail preferences and try again.

RESOLVED INVALID

Status

RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: win22, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: version 3.0a1pre (2007110704)

An error occurred while sending mail. The mail server responded:  Sender address and login must be equal..  Please verify that your email address is correct in your Mail preferences and try again.

It's message every time, when I try to send mail from secondary account.

I have 3 account in server pochta.ru.   

When I add them in chain in Thunderbird, they are acc1@pochta.ru, acc2@pochta.ru,acc3@pochta.ru.

result: receiving mail - all  3 account receive mail correct.
        sending mail - acc1@pochta.ru sending mail correct.
                       acc2  and acc3 return error message (see above)

IMHO it was because Thunderbird use the first acc1 SMTP server settings for all the next accounts, and related it with acc1 login.  

I don't find way, how to change SMTP server settings different for each account name. 

Reproducible: Always

Steps to Reproduce:
1.Add accounts as following installation prompt.

2.Add next account, same way, excluding SMTP settings, because TB use it from the first account.
3.Try to send mail from one account to another.
from acc1 to acc2 and acc3 mail sends OK,  From acc2 and acc3 to acc1 - have ERROR MESSAGE.
Actual Results:  
I can receive mail on all 3 accounts, and can send from any of them, which was first added.

Expected Results:  
I think, that software should advice enter smtp server separately for any new account added, as was before (in old versions)

For example, eudora, and MS Outlook with the same accounts settings works properly, send and receive,(just slowly, than TB) just I try to migrate to Debian, so try Linux application now. 

If some additoinal information is needed, just ask me -i'm ready to help if I can.
I don't know if you mean identities or accounts, but thunderbird lets you set up outgoing server settings even per identity. Just add a new SMTP first - those are at the bottom of the account settings. 

Thunderbird support forums are here:
http://forums.mozillazine.org/viewforum.php?f=39

->INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.