Using Gmail in IMAP mode in TB, downloading a ZIP from a mail message corrupts the file (Gmail IMAP returns incorrect RFC822.SIZE)

RESOLVED DUPLICATE of bug 390795

Status

defect
--
major
RESOLVED DUPLICATE of bug 390795
12 years ago
7 years ago

People

(Reporter: jgordon00, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Downloading of attached ZIP from Gmail IMAP causes corruption of file

I recently setup TB to access Gmail through IMAP. I noticed that if I receive an email message containing an attached ZIP, when I download it to my desktop and open it, it is ALWAYS corrupted.

I did some testing to get more information:

1) I setup Gmail in IMAP mode in Outlook Express (had no problems with the same ZIP file)

2) I downloaded the ZIP file directly from Gmail (web version). Again, I had no problems with the file.

Reproducible: Always

Steps to Reproduce:
1.Setup your Gmail account on Thunderbird in IMAP mode. Make sure to follow the instructions from Google (correct server ports, etc...)

2.From another email account, send a message with an attached ZIP file to your Gmail account.

3. In Thunderbird, download the ZIP in the new message to your desktop and try to open it. 
Actual Results:  
Attached ZIP files get corrupted every time.

Expected Results:  
I expected the ZIP files to be fine.
Bug 403039 reported similar problem with Gmail IMAP on Base64 encoded PDF attachment.
Read meta Bug 402793 Comment #1, and check protocol level flow, please.
Is Tb's fault involved? Or incorrect RFC822.SIZE by Gmail IMAP?
Blocks: tb-gmailWIP
I did some hunting based on comments in other bugs that were related to this...

There is a solution to this issue of corrupted attachments with Gmail IMAP in Thunderbird --- here's what I found in a Google Groups posting
(http://groups.google.com/group/Gmail-Problem-solving/browse_thread/thread/28f5c7328725fa6e/cd08510b98c01b50?hl=en&lnk=st&q=#cd08510b98c01b50)

SOLUTION:
==============
Choose Tools - Options - Advanced - General and press the Config Editor... button. You will be brought to a long list of preferences.

Using the filter entry box at the top, type in mail.server.server and you will see a list of keys and values. One of those keys will be mail.server.serverX.name, where X is a number and the value is the name of your Gmail IMAP account. Remember X. To add a new preference,context click (right-click on most systems) anywhere and choose New and boolean.

A dialog box will pop up asking for the name of your new key. Put in
mail.server.serverX.fetch_by_chunks, where X is the number you remember from above. A new box will come up asking for the value of your new key. Choose false.

The second choice is to open the file pref.js with a text editor located in your Thunderbird profile (see help for Thunderbird, to see where it is) and add a line like this:

user_pref(mail.server.serverXX.fetch_by_chunks, false)

where XX is the number of the server for gmail imap. 
===================

Hope this helps people!
Same report as Bug 403039, so closing as DUP of Bug 390795.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 390795
Summary: Using Gmail in IMAP mode in TB, downloading a ZIP from a mail message corrupts the file → Using Gmail in IMAP mode in TB, downloading a ZIP from a mail message corrupts the file (Gmail IMAP returns incorrect RFC822.SIZE)
You need to log in before you can comment on or make changes to this bug.