can't type in Composer (initially)

VERIFIED WORKSFORME

Status

()

P3
blocker
VERIFIED WORKSFORME
19 years ago
17 years ago

People

(Reporter: Brade, Assigned: adamlock)

Tracking

({regression, smoketest})

Trunk
regression, smoketest
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood+] will verify after 40342 is fixed)

(Reporter)

Description

19 years ago
With a pull/build on mac from today, I can't type in Composer.  I can type in 
edit fields such as the urlbar.

jst says this doesn't work on linux or windows.
(Reporter)

Updated

19 years ago
Keywords: regression, smoketest
Target Milestone: --- → M16

Comment 1

19 years ago
is this possibly a dup of 40308?
granrose might be on to something.

in #40308, I was seeing JS errors to the console.

I'll try to get the console output for composer, and report back.
wacky, when I did -P editor, I got this error,
but when I launched editor from messenger, it worked.  (at least, it did once.)

not 100% sure the two bugs are related, since I'm not seeing any JS errors to 
the console when editor fails to work.
(Reporter)

Comment 4

19 years ago
nsEditorShell::OnEndDocumentLoad doesn't get called.

Comment 5

19 years ago
Putting on [dogfood+] radar.
Whiteboard: [dogfood+]
(Reporter)

Comment 6

19 years ago
HarishD and I have tracked it down a bit further:
in nsWebShell.cpp, OnEndDocumentLoad... 
the difference in runtime between yesterday and today is that dlObserver->
OnEndDocumentLoad isn't getting called today (around line 1189)

dlObserver is null, as is mDocLoaderObserver

Comment 7

19 years ago
I'm going to assign this to Adam for the time being -- Adam, do you have any 
idea as to what is going on?
Assignee: beppe → adamlock

Comment 8

19 years ago
Okay, so like I'm special :-] I can type in composer under any set of 
conditions, with either today's commercial or mozilla builds. I am on win95.
Just a data point ... 

Comment 9

19 years ago
And I couldn't reproduce the problem either!

Comment 10

19 years ago
Actually, I'm told that the issue is that the "first" time, you can't type
in composer, but if you reset the focus once or twice, typing then works. 
Is that correct? (I'll shut up now).
Summary: can't type in Composer → can't type in Composer (initiallY)

Comment 11

19 years ago
For the initial window, I can't find any action that wakes up the editor -- 
tried inserting elements, resizing, etc.
I can get an editor by starting a browser, open a file, then use File | 
Edit Page.

Comment 12

19 years ago
Yup..this happens only on the initial load [ verified on today's mac. build ].

Should we hold the tree closed for this? There seems to be a work around.

Comment 13

19 years ago
What do we need to do to verify this? I thought I found the culprit (the fix for
40308 I did find). But I just discovered that with or without my fix for 40308,
I can run -editor and type in the edit window without a problem.

Is there something special I need to do to see this problem?

Comment 14

19 years ago
Remove component.reg and restart mozilla [was able to reproduce on mac. but not 
on windows ]
after all the docshell changes, I'm not able to reproduce this anymore.

Summary: can't type in Composer (initiallY) → can't type in Composer (initially)

Comment 16

19 years ago
I cannot reproduce this after tossing everything. MacOS pull from 8pm-ish.

Comment 17

19 years ago
this is workingforme on linux, marking so.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 18

19 years ago
will verify after 40342 is fixed
Whiteboard: [dogfood+] → [dogfood+] will verify after 40342 is fixed
(Reporter)

Comment 19

19 years ago
not sure what 40342 has to do with composer... typo?

Comment 20

19 years ago
verified on all platforms using 5/24 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.