♥ displays as a vertical bar instead of a heart

RESOLVED DUPLICATE of bug 212745

Status

Core Graveyard
GFX: Mac
RESOLVED DUPLICATE of bug 212745
10 years ago
9 years ago

People

(Reporter: Attie, Unassigned)

Tracking

1.8 Branch
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

Any use of the special ♥ character in the body of a page results in a vertical bar instead of a heart. (Use in the page title works.) The same page displays fine in other browsers.

Reproducible: Always

Steps to Reproduce:
1. open page containing ♥
Actual Results:  
Displays a vertical bar.

Expected Results:  
Display a heart.

This has been reported by a wide variety of users from across all systems. There are a lot of people who'd like to see this one fixed, as it's been an annoyance for years to people who would like to express appreciation.

Comment 1

10 years ago
Please search for duplicates before reporting bugs in bugzilla, see bug 260101, bug 281038 or bug 307350.

This will be fixed in Firefox 3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Component: General → GFX: Mac
OS: All → Mac OS X
Product: Firefox → Core
Hardware: All → Macintosh
Resolution: --- → DUPLICATE
Version: unspecified → 1.8 Branch
Duplicate of bug: 212745
(Reporter)

Comment 2

10 years ago
Okay, sorry, I searched for half an hour without any results. None of the searches for "heart", "hearts", "♥", or "special character" brought up any of these bugs. Is there a way to make it easier to find previously reported bugs?

Comment 3

10 years ago
You need to include closed bugs that are marked as duplicate into the search. The "Advanced Search" does this by default, in the simple search form you need to set Status to "All" to include those (there should probably be some text explaining this).

Comment 4

10 years ago
Problem is not restricted to ♥ the other playing card symbols (♠  ♦ ♣) also display as vertical bars. If someone starts to work this problem, I can look for more instances.
(Assignee)

Updated

9 years ago
Product: Core → Core Graveyard

Comment 5

9 years ago
This appears to be fixed, at least for my limited sampling, in Firefox 3.0.5.
(Using Mac OS X Version 10.4.11 on an iMac.)
You need to log in before you can comment on or make changes to this bug.