Closed Bug 403198 Opened 12 years ago Closed 12 years ago

Need to bump maxversion to accept 3.0b3pre

Categories

(Other Applications Graveyard :: QA Companion, defect, blocker)

defect
Not set
blocker

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: zach, Assigned: cmtalbert)

Details

Attachments

(1 file, 1 obsolete file)

The extension is now incompatible with the trunk because maxversion doesn't allow 3.0b2pre. We need to bump the maxversion string so it stays useful.
Status: NEW → ASSIGNED
Severity: normal → blocker
Summary: Need to bump maxversion to accept 3.0b2pre → Need to bump maxversion to accept 3.0b3pre
Attached patch Makes the change to use 3.0b* (obsolete) — Splinter Review
I only changed the em:maxVersion="3.0b*" line, but I also corrected the line endings of this file from CRLF to LF. (hence the every single line change in the diff)
Assignee: zach → ctalbert
Attachment #296455 - Flags: review?(zach)
Comment on attachment 296455 [details] [diff] [review]
Makes the change to use 3.0b*

Per https://addons.mozilla.org/en-US/firefox/pages/appversions, 3.0b* is not a valid maxversion for AMO. Since the goal is, as I understand it, to host the extension on AMO, we should probably stick with 3.0b3, the most recent version we can use. We can bump the maxversion later once b3 comes out (this can be done from the AMO control panel without rebuilding the whole package if no changes need to be made iirc). 

Feel free to checkin without further review if you switch it to 3.0b3.

Also, when this goes on AMO, the updateURL field will need to be removed, but that can happen later. 

Sorry about the line endings with this file--I think I stole the format from another extension; we should go through the source tree at some point and make sure everything is consistent.
Attachment #296455 - Flags: review?(zach) → review-
Zach, Made the change to 3.0b3 and +'d the review (as you directed).  I'd forgotten about that restriction.  Thanks.  However, we're currently hosting this off my people.mozilla.org account, so I updated the UpdateURL to point there as well.  I'll go ahead and check this in unless you have concerns about it.
Attachment #296455 - Attachment is obsolete: true
Attachment #296617 - Flags: review+
Comment on attachment 296617 [details] [diff] [review]
Change to 3.0b3 and update url

Looks good, let's get this checked in so we at least have a working version for Firefox 3.
Attachment #296617 - Flags: review+
Whiteboard: needs landing
Patch checked in on trunk -->FIXED
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Verified FIXED with the QAX v0.1.6 extension available at http://people.mozilla.com/~ctalbert/QAX/latest_QAX.xpi, using the following builds:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b3pre) Gecko/2008012104 Minefield/3.0b3pre

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b3pre) Gecko/2008012104 Minefield/3.0b3pre

-and-

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2008012104 Minefield/3.0b3pre

I filed bug 413456 to get the extension/add-on signed, which I feel is something we should do before we host on AMO.
Status: RESOLVED → VERIFIED
Whiteboard: needs landing
Product: Webtools → Other Applications
Version: Trunk → unspecified
Product: Other Applications → Other Applications Graveyard
You need to log in before you can comment on or make changes to this bug.