Zooming triggers "WARNING: Unable to test style tree integrity -- no content node"

RESOLVED FIXED in mozilla24

Status

()

--
minor
RESOLVED FIXED
11 years ago
5 years ago

People

(Reporter: jruderman, Assigned: dholbert)

Tracking

({regression})

Trunk
mozilla24
regression
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Ctrl++ or Ctrl+- on any page triggers:

WARNING: Unable to test style tree integrity -- no content node: file /Users/jruderman/trunk/mozilla/layout/base/nsCSSFrameConstructor.cpp, line 10110

This even happens on the empty page
data:text/html,
We're doing a style change on the viewport.  That's rare, but can happen....
(Reporter)

Comment 2

11 years ago
It's not rare any more... can we change the assertion so it doesn't fire in this case?
It's not an assertion... it's a warning.  And it _is_ rare compared to style changes in general.  ;)

We could probably skip the warning if the frame is a viewport... or even altogether. David, sound OK?
(Assignee)

Comment 4

5 years ago
We hit this at pageload time, for files with <meta charset="utf-8">, since the charset-change happens asynchronously and triggers a rebuild of all style data starting with the viewport frame.

I agree that we should skip the warning if the frame is a viewport. (I was actually just about to file a bug on making that change, and then I ran across this one from bugzilla's new-bug-form dupe-finder.)
(Assignee)

Updated

5 years ago
OS: Mac OS X → All
Hardware: x86 → All
(Assignee)

Comment 5

5 years ago
Minimal testcase that demonstrates the beginning of comment 4:
  data:text/html,<meta charset="utf-8">
(Assignee)

Comment 6

5 years ago
Created attachment 763872 [details] [diff] [review]
fix v1

This patch skips the warning if we have a frame and it's a viewport frame.
Assignee: nobody → dholbert
Status: NEW → ASSIGNED
Attachment #763872 - Flags: review?(bzbarsky)
Comment on attachment 763872 [details] [diff] [review]
fix v1

r=me
Attachment #763872 - Flags: review?(bzbarsky) → review+
(Assignee)

Updated

5 years ago
Flags: in-testsuite-

Comment 9

5 years ago
https://hg.mozilla.org/mozilla-central/rev/1e93bc25a700
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
You need to log in before you can comment on or make changes to this bug.