Firefox repeatedly crashing X server

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: Tom Oldbury, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.8) Gecko/20071022 Ubuntu/7.10 (gutsy) Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.8) Gecko/20071022 Ubuntu/7.10 (gutsy) Firefox/2.0.0.8

Seems in Linux/Ubuntu Gutsy if you click on a link then highlight text while the page is loading, everything freezes on Firefox and the computer, including all panel widgets (my Wanda the Fish animation stops, as does the clock), but the mouse will still work. I'm not able to SSH in to the PC because I'm fairly new to Linux but I suspect this is a crash of the X server or a system component. 

Reproducible: Always

Steps to Reproduce:
1. Click on a web link.
2. While the page is loading, and still on the original page, click on another link or highlight text. 
3. Reboot and continue with work. System seems unaffected after this crash. 
Actual Results:  
Everything stopped, including the clock and my Wanda animation. Mouse still moves though, but no system beeps from holding down 10 keys at a time. 

Expected Results:  
Nothing really. On Windows, you'd just get highlighting or going to the other page you clicked. 

Default theme, Ubuntu Linux Gutsy (not beta), Firefox 2.0.0.9. Emerald theme manager. Compiz with some add ons, but mostly stable ones. No problems without using Firefox.

Comment 1

9 years ago
Using Firefox trunk (3.7a1pre) on Ubuntu 9.10, I don't get crashes.  But if I'm in the middle of drag-selecting when a page loads, Firefox starts ignoring mouse events, which is almost as bad as a crash.

Comment 2

9 years ago
But using Firefox 3.5.5 (also on Ubuntu 9.10), everything works perfectly.  So I'm probably seeing an unrelated bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Comment 3

9 years ago
Filed bug 528829 on the issue I described in comment 1.
You need to log in before you can comment on or make changes to this bug.