Closed Bug 403320 Opened 12 years ago Closed 10 years ago

Starting Firefox get a message three times stating Firefox could not install this item because of a failure in Chrome Registration

Categories

(Firefox :: General, defect)

2.0 Branch
x86
Windows Vista
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mrwdc, Unassigned)

Details

(Whiteboard: [CLOSEME 2010-07-30])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

On starting Firefox a message screen pops up reading "Firefox could not install this item because of a failure in Chrome Registration. Please contact the author about this problem."  I click on the OK button and the same screen pops-up two more times before Firefox starts.  Once open it operates normally.  This started about 10 days ago after an update to Firefox, after which I did get a message that some of the plug-ins no longer worked. I did not note which ones as that has happened before and it has not been a problem.

Reproducible: Always

Steps to Reproduce:
1. Start Firefox - get message - click ok - get message - click ok - get message click ok - Firefox starts normally
2.
3.
Actual Results:  
Get 3 "failure in chrome Registration" messages

Expected Results:  
Firefox should just start
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.9)
> Gecko/20071025 Firefox/2.0.0.9
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.9)
> Gecko/20071025 Firefox/2.0.0.9
> 
> On starting Firefox a message screen pops up reading "Firefox could not install
> this item because of a failure in Chrome Registration. Please contact the
> author about this problem."  I click on the OK button and the same screen
> pops-up two more times before Firefox starts.  Once open it operates normally. 
> This started about 10 days ago after an update to Firefox, after which I did
> get a message that some of the plug-ins no longer worked. I did not note which
> ones as that has happened before and it has not been a problem.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1. Start Firefox - get message - click ok - get message - click ok - get
> message click ok - Firefox starts normally
> 2.
> 3.
> Actual Results:  
> Get 3 "failure in chrome Registration" messages
> 
> Expected Results:  
> Firefox should just start
> 
hey i get the same problem and cant figure it out either if you have gotten a response it would be great to hear how to fix this

I also started seeing this behavior just over a week ago after Firefox updated an HTML Validator Add-on. Unfortunately, I'm now getting none of my add-ons when Firefox finally runs, which is particularly bad, since I need the validator and the Web Developer tools for the work I'm doing. 

I'm using a Lenovo Thinkpad, running Vista Business. 

I've seen this message before, after previous Add-on updates, but the message never appeared three times consecutively, and the Add-ons were still working. The messages stopped appearing eventually. 

In this case it's been going on for days. 
I have been getting this error since FF upgraded to 2.0.0.9.
Was hoping it would disappear on the next upgrade but today got 2.0.0.10 and is still happening.


Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.8.1.10) Gecko/20071115 Firefox/2.0.0.10

Would like a fix for this is a real pain
I got the error message to go away by uninstalling the HTML Validator add-on and the Web Developer add-on, then disabling the Firefox Talkback add-on and the Thinkpad ThinkVantage Password Manager tool (comes installed on Thinkpads). 

When I restarted Firefox, the error didn't appear. 

I re-installed the HTML Validator and the Web Developer add-ons and still no error. 

Talkback and ThinkVantage Password Manager are still disabled, but that really doesn't bother me.
>Hi there.Got the same problem and I tried to fix it nearly your way.It didn't work.I have Talkback add on,DOM Inspector and AllPeers beta.I disabled the first two and restarted Firefox But the failure's still there.I think,that it is not caused by AllPeers,because it worked with firefox 2.0.0.8 just great.Troubles started after upgrade to newer version.Any idea?Cheers
I have just tried uninstalling all my add ons, but can seem to get rid of them, get the message this add on will be uninstalled when FF is restarted . I then restart but they are not uninstalled even after a reboot.
Think the next thing to try is an uninstall/reinstall of FF
uninstalled. downloaded setup v 2.0.0.11 and seems to have fixed it
This bug is much like #311480. It has either regressed or was not properly fixed the first time round.

Googling for this error shows that many are encountering this problem when trying to launch FF with non-admin permissions. Apparently FF needs to write to a restricted location on first use by a user.
I had this issue and I resolved it by running Firefox as an Administrator for the 1st run after an update. 

I think this has something do with the chrome registry being in the Program Files directory which you can only write when you are in "Administrator Mode".
Hi, 

I had same bug after adding the alexa toolbar. 

"Firefox could not install this item because of a failure in Chrome Registration. Please contact the author about this problem."
I was gtting this 2/4/6 times followed by the plug-in window before firefox startup.

I CURED THIS BY GOING TO:

Program files - Mozilla Firefox - Properties - Security :-

When in secity file of properties change permissions for users to allow all for your pc.

Bug cured : )

Micky Kidd
(In reply to comment #10)
> Hi, 
> 
> I had same bug after adding the alexa toolbar. 
> 
> "Firefox could not install this item because of a failure in Chrome
> Registration. Please contact the author about this problem."
> I was gtting this 2/4/6 times followed by the plug-in window before firefox
> startup.
> 
> I CURED THIS BY GOING TO:
> 
> Program files - Mozilla Firefox - Properties - Security :-
> 
> When in secity file of properties change permissions for users to allow all for
> your pc.
> 
> Bug cured : )
> 
> Micky Kidd

Thanks ..I Went to mozilla and Right Clicked on firefox and security allow all worked for me to..
This bug was originally reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.6 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
Whiteboard: [CLOSEME 2010-07-30]
Version: unspecified → 2.0 Branch
Working through the Firefox basic troubleshooting document should fix this issue. http://support.mozilla.com/en-US/kb/Basic+troubleshooting
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.