assertion when I launch the account wizard

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Account Configuration
P3
normal
VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: Chris Waterson)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

to reproduce, assuming you don't have a profile named foobar,

mozilla -CreateProfile foobar
mozilla -P foobar -mail

(you'll get it when the wizard, when mailnews opens, because there are no 
accounts)

here's the assertion

NTDLL! 77f7629c()
nsDebug::Assertion(const char * 0x100be4d0, const char * 0x100be4a0, const char 
* 0x100be470, int 515) line 242 + 13 bytes
nsFileURL::nsFileURL(const char * 0x0330c9f8, int 0) line 515 + 48 bytes
nsFileSpecImpl::SetURLString(nsFileSpecImpl * const 0x0330cd60, const char * 
0x0330c9f8) line 126 + 14 bytes
GetConvertedChromeURL(const char * 0x01adda6c, nsIFileSpec * * 0x0012dc84) line 
102 + 36 bytes
nsMsgServiceProviderService::Init() line 136 + 34 bytes
nsMsgServiceProviderServiceConstructor(nsISupports * 0x00000000, const nsID & 
{...}, void * * 0x0012dd44) line 113 + 146 bytes
nsGenericFactory::CreateInstance(nsGenericFactory * const 0x0330a030, 
nsISupports * 0x00000000, const nsID & {...}, void * * 0x0012dd44) line 48
nsComponentManagerImpl::CreateInstance(nsComponentManagerImpl * const 
0x00c54460, const nsID & {...}, nsISupports * 0x00000000, const nsID & {...}, 
void * * 0x0012dd44) line 1198 + 24 bytes
nsComponentManager::CreateInstance(const nsID & {...}, nsISupports * 0x00000000, 
const nsID & {...}, void * * 0x0012dd44) line 82
nsServiceManagerImpl::GetService(nsServiceManagerImpl * const 0x00c547d0, const 
nsID & {...}, const nsID & {...}, nsISupports * * 0x0012ded8, 
nsIShutdownListener * 0x00000000) line 343 + 19 bytes
nsServiceManagerImpl::GetService(nsServiceManagerImpl * const 0x00c547d0, const 
char * 0x0012df78, const nsID & {...}, nsISupports * * 0x0012ded8, 
nsIShutdownListener * 0x00000000) line 482
nsServiceManager::GetService(const char * 0x0012df78, const nsID & {...}, 
nsISupports * * 0x0012ded8, nsIShutdownListener * 0x00000000) line 595
RDFServiceImpl::GetDataSource(RDFServiceImpl * const 0x01069710, const char * 
0x0012e1bc, nsIRDFDataSource * * 0x0012e294) line 1122 + 50 bytes
nsXULDocument::CheckTemplateBuilder(nsIContent * 0x03309240) line 5641 + 61 
bytes
nsXULDocument::ResumeWalk() line 4881 + 14 bytes
nsXULDocument::OnStreamComplete(nsXULDocument * const 0x032ce2e8, 
nsIStreamLoader * 0x00000000, nsISupports * 0x00000000, unsigned int 0, unsigned 
int 3553, const char * 0x027abee8) line 5274 + 11 bytes
nsStreamLoader::OnStopRequest(nsStreamLoader * const 0x032cdc14, nsIChannel * 
0x03254dd0, nsISupports * 0x00000000, unsigned int 0, const unsigned short * 
0x00000000) line 120 + 78 bytes
nsResChannel::EndRequest(unsigned int 0, const unsigned short * 0x00000000) line 
758 + 50 bytes
nsResChannel::OnStopRequest(nsResChannel * const 0x03254dd4, nsIChannel * 
0x02e95560, nsISupports * 0x00000000, unsigned int 0, const unsigned short * 
0x00000000) line 752
nsFileChannel::OnStopRequest(nsFileChannel * const 0x02e95564, nsIChannel * 
0x032d8f60, nsISupports * 0x00000000, unsigned int 0, const unsigned short * 
0x00000000) line 625 + 45 bytes
nsOnStopRequestEvent::HandleEvent(nsOnStopRequestEvent * const 0x032d8970) line 
307
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x032d8850) line 97 + 12 bytes
PL_HandleEvent(PLEvent * 0x032d8850) line 575 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x02f77d00) line 520 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x012e033a, unsigned int 49334, unsigned int 0, 
long 49773824) line 1030 + 9 bytes
USER32! 77e71820()
02f77d00()
I forgot to add that I can continue on after the assert.

Comment 2

18 years ago
Can you try again? I think I swear I fixed this last night. (update 
mailnews/base/src)

Comment 3

18 years ago
oh, wait, I fixed the CRASH.
Hyatt, I'm trying to resolve a chrome URL for a directory that doesn't exist - I 
don't believe the proper thing to do is assert - previously, you'd just return a 
null pointer to the filter object if the dir didn't exist. This behavior is new, 
but I don't know if nsFileURL changed, or the filters code changed.
Assignee: alecf → hyatt

Comment 4

18 years ago
enjoy
Assignee: hyatt → waterson
(Assignee)

Comment 5

18 years ago
WORKSFORME (no assertion) on a build pulled 10am, 2000-05-30.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 6

18 years ago
Works for me:
Platform: PC
OS: Windows 98
Mozilla Build: 2000101214 M18 Trunk Build

Marking as Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.