Dropdown menus do not re-position when page zoom is changed with Ctrl-+/-

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
5 years ago

People

(Reporter: jra, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

1) When text is resized using Ctrl-+/-, the displayed choice in a dropdown has it's text resized, but the height of the pulldown does not adjust properly on resize step +2, concealing some of the label.

2) When Ctrl-+/- is used to resize text while a saved reply list panel is extended, that text does not resize, nor does the response panel reposition properly to track the text entry field of the dropdown; it will be left floating where it was in the viewport, though still fully functional.

Reproducible: Always

Steps to Reproduce:
1. Load a webpage with dropdown menus
2. Ctrl-+ twice
3. Note clipped text
4. Ctrl-0 back to default
5. Load www.google.com;
5. Click in the search field
6. Hit Dn-Arrow to display previously entered searches
7. Ctrl-+ to increase text size; note the behavior of the saved replies dropdown
Actual Results:  
As noted in the Summary

Expected Results:  
I would expect that the dropdown box would always resize to the proper height for the enclosed text, and that saved reply dropdown panels would resize and reposition when the text size is changed.

This doesn't seem to be font-dependent, from my testing.
(Reporter)

Comment 1

11 years ago
I filed this in OS integration because I'm not sure whether it's Windows specific and haven't any other OS version handy to test on.  I assume that it's just above where Firefox meets the OS toolkit, but it could be a limitation of the toolkit itself; feel free to recategorize, but I didn't see Gecko as a component or I' have put it there.

Comment 2

11 years ago
I use CTRL-+ often to make the web easier to read.  I am not sure if this should be another bug but here are my problems with it and fixxes might be around but i just do not know about them.:
1.  ctrl-+ does not seem to be an option that can be more or less applied to my entire browing experience.
2.  ctrl-+ increases the frame? size (but not always)to exceed screen size meaning that i may not read it all without having to scroll left and right.  Ideally i would like to gain control of this such that the frame that i am reading fits neatly within my window and the text is as large as easily readable.
3.  Ideally I would like to be able to force wrap on to screen size when frame size is forced to exceed screen size to prevent having ot scroll left and right as well as up and down.

I suppose that this is an accessibility issue the way i usually use it.
Component: Shell Integration → Layout: Form Controls
Product: Firefox → Core
QA Contact: shell.integration → layout.form-controls
Severity: trivial → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: x86 → All
Summary: Dropdown menus on webpages respond incorrectly when text resized with Ctrl-+/- → Dropdown menus do not re-position when page zoom is changed with Ctrl-+/-
Version: unspecified → Trunk
I believe this has been fixed since this bug has been opened because the current behaviour looks correct.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.