Closed Bug 403380 Opened 13 years ago Closed 13 years ago

mochitests always fail on second pass

Categories

(Toolkit :: Password Manager, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla1.9beta3

People

(Reporter: wgianopoulos, Assigned: Dolske)

Details

Attachments

(1 file)

If you run all the mochitests and they pass, and then click back on the run all tests link, you will get 6 failures in the password manager section.

This is because the password manager tests fail if there are any saved passwords existing when they start.  However, they don't clean up after themselves and leave 2 saved passwords when they complete.

You can verify this is the cause by manually removing all saved passwords before running a second test pass.
Should be easy enough to fix with a final test that calls removeAllLogins().
Assignee: nobody → dolske
Attached patch Patch v.1Splinter Review
Target Milestone: --- → Firefox 3 beta4
Checked in.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Target Milestone: Firefox 3 beta4 → Firefox 3 beta3
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.