Issues with Yahoo! Email Beta (and IM applications ?)

RESOLVED DUPLICATE of bug 421303

Status

()

--
critical
RESOLVED DUPLICATE of bug 421303
11 years ago
11 years ago

People

(Reporter: b_nichols, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

I'm quite sure this is related to other bugs, but doesn't seem to be an exact match.

FF 2.0.0.9 doesn't play nicely with Yahoo Email beta, earlier versions of FF had transient issues, this seems to be much worse.  

Scenarios:
(1) I'm using FF, have 6-8 tabs open.  Go to YMB, login, read a message, respond to message, click send, then click logout.  FF 2.0.0.9 crashes 90% of the time.

(2) Using Yahoo IM, I'm notified of a new email message.  Clicking on the notification logs me in, I open mail, respond, send, logout, FF crashes.

Recently started using Pidgin to manage multiple IM clients, same scenario as (2) above in terms of accessing YMB, tends to be crashing closer to 100% of the time than 90% 

Reproducible: Sometimes

Steps to Reproduce:
1Start FF.
2. Start an IM client, either Yahoo or Pidgin
3. Receive email notification of new message from IM application.
4. Click on provided link from IM application to go to Yahoo Email Beta.
5. Respond to email.
6. Send email.
7. Logout of Yahoo Email.
8. FF crashes.

Actual Results:  
FF crashes and has to be restarted.  Get the MSFT "Honest, we're tracking all these bugs, please report this one" message.

Expected Results:  
Logout screen from Yahoo.

I'm sure this is related to a lot of other bugs, but I can say this:
1) it's MUCH worse in 2.0.0.9
2) I'm willing to put some effort into tracking it down, provided someone tells me what they need.
Created attachment 313276 [details]
Crash Reports and Data

See comment from Charles Templeton in main bug report.
Comment on attachment 313276 [details]
Crash Reports and Data

I have experienced the same exact problem with Firefox 2.0.0.12 & 2.0.0.13. I got so fed up with it I started playing around with it. Here is what I found. The bug is not repeatable without running the Firebug extension. Once the Firebug extension is enabled the crashing rate on closure of tab with the Yahoo Mail Beta or quiting of FireFox with the Mail Beta open will certainly cause a crash. Due to this association with the Firebug extension I posted the text below originally toe the Firebug bug tracking system located at http://code.google.com/p/fbug/issues/detail?id=557. It was requested that I report this bug here. (That is how I found this page.)

Here is how you recreate the bug described above.

1. Load Firefox 2.0.0.13 with Firebug v1.05 (problem is not reproducible
with Firefox alone.) 
2. Go to http://mail.yahoo.com. Ensure that you are viewing the Beta
version of Yahoo! Mail  
3. Either Close the Tab that Yahoo! Mail Beta is in or quit Firefox. Upon 
closing the tab Firefox will crash and give you an error. If you quit
Firefox the main window will close then the program will crash. 

  I have turned off all my extensions and the problem is NOT reproducible
with Firefox alone. I then turned on each of my add-on individually to see
if it was a single offending extension that was causing the problem. I was
able to reproduce the problem with only the Firebug extension turned on. 

  I have not always had this problem. In the past I have been able to use
the Yahoo! Mail Beta with Firebug extension turned on without crashing.
This problem started occurring about the time Firefox 2.0.0.12 was
released. (I do not know if it was associated with the update of Firefox or
some update of Firebug.)

I am currently running WindowsXPSP2. I have attached a ton of information
dumps from Mozilla Talkback, Windows Error Reporting and the Application
Event Records. I have also included "saves" of the about: pages from
Firefox and some other miscellaneous information that might be helpful.

If I can provide any more information about this that would be helpful
please feel free to contact me.

- Charles

Comment 3

11 years ago
sorry, the talkback report is only useful if you provide a talkback id,
http://kb.mozillazine.org/Talkback

alternatively, you could use windbg:
http://developer.mozilla.org/en/docs/How_to_get_a_stacktrace_with_WinDbg

if you catch a crash then while the windows error dialog is open, there's information pointing to a .dmp file which windbg can analyze.

npzzatif (Medical Informatics Engineering ??) is odd and npmozax is hardly something i'd "Support", you also have macromedia authorware (which i don't recognize), shockwave (which i rarely see these days), a divx player and viewpoint in addition to the normal WMP, Adobe PDF and QuickTime plug-ins.

disabling all plug-ins and extensions (the latter can be done using safe mode, the former is harder), would be a good idea. but please get either a talkback incident id, or a stack trace (from windbg).
I recreated the crash with No plug-ins this time to ensure that it was not an issue with the plug-ins. Here is the link to the "talkback" report for the recreated crash:

http://talkback-public.mozilla.org/search/start.jsp?search=2&type=iid&id=TB43532919Y

I will attach a stack trace I got from WinDebug.

I have not been able to recreate this in FF3b5.
Created attachment 313863 [details]
This is a stack trace of the crash

Here is a stack trace of the crash after closing the Yahoo! Mail Beta. I was only running the Firebug extension will all other plug-ins and extensions turned off.

Comment 6

11 years ago
i'm assuming the stack was from <3.0b5 (where this was fixed)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 421303
You need to log in before you can comment on or make changes to this bug.