Last Comment Bug 403408 - Non-existent favicon.ico requested twice in a row in short time
: Non-existent favicon.ico requested twice in a row in short time
Status: RESOLVED INCOMPLETE
[CLOSEME 2010-07-30]
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: 2.0 Branch
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 443660 468098 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 11:41 PST by The Reporter
Modified: 2010-08-16 21:11 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description The Reporter 2007-11-11 11:41:32 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

Firefox requests twice in a row in short time a favicon.ico file that does not exist. The server returns "HTTP 410 Gone". I didn't test HTTP 404.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.


Expected Results:  
Request the favicon.ico file only once. Not twice in a row in a short time, which wastes bandwidth both of the user and of the server, etc.
Comment 1 The Reporter 2007-11-11 11:45:09 PST
By "short time" I mean anything between 0.01 and several seconds.
Comment 2 Jo Hermans 2007-11-11 11:50:48 PST

*** This bug has been marked as a duplicate of bug 299031 ***
Comment 3 The Reporter 2007-11-11 12:11:52 PST
This is not a duplicate of the bug 299031. The bug 299031 does not deal with re-requesting the favicon.ico file TWICE on a SINGLE page load. That bug deals with re-requesting the favicon.ico file on SUBSEQUENT page loads. This is about a single page being loaded and favicon.ico requested twice in near-zero time. 

Read what I wrote. It may apply to HTTP 404 (I haven't tested that). These bugs are not duplicate. 
Comment 4 The Reporter 2007-11-11 12:15:41 PST
You request a page widget.html:

Firefox does:
GET widget.html
GET favicon.ico
GET favicon.ico

All that within less than one second.
Comment 5 Jo Hermans 2007-11-11 12:18:03 PST
no : read bug 299031 comment 2. A 410 should be cached (point 2). And a favicon request might also be treated differently form a regular request (point 1).
Comment 6 The Reporter 2007-11-11 12:30:26 PST
First, I don't see HTTP 404 mentioned anywhere. This bug may affect 404 too.

Second, let me quote from the first post, the actual bug report, 299031.

"Our server returns 410 for the /favicon.ico file. Despite that Firefox keeps 
requesting the file while the user continues browsing other pages on the same 
site (e.g. domainc.com/index.html and then domain.com/some.html)."

Note the words "other pages on the same site".

This bug is about only a SINGLE PAGE request. That bug is about CACHING results between requesting MULTIPLE PAGES, possible minutes or hours between.
Comment 7 Aaron Slunt 2008-07-05 18:52:18 PDT
*** Bug 443660 has been marked as a duplicate of this bug. ***
Comment 8 Jeff Walden [:Waldo] (remove +bmo to email) 2008-12-05 09:52:27 PST
*** Bug 468098 has been marked as a duplicate of this bug. ***
Comment 9 Jeff Walden [:Waldo] (remove +bmo to email) 2008-12-05 09:55:13 PST
Easy-to-use steps to reproduce, no external server access or packet watching needed:

$ cd $srcdir
$ echo "var DEBUG = true;" > testing/mochitest/server.js.new
$ cat testing/mochitest/server.js >> testing/mochitest/server.js.new
$ mv testing/mochitest/server.js{.new,}
$ python $OBJDIR/_tests/testing/mochitest/runtests.py --test-path=q

...and watch the debug output for two /favicon.ico requests.
Comment 10 Brian Carpenter [:geeknik] 2009-04-06 18:48:35 PDT
On my linux box, I ran 'python -m SimpleHTTPServer' and visited the site using Firefox 3.5b4pre Build 20090406050537 and Firefox requested the /favicon.ico twice.

MASTER - - [06/Apr/2009 20:44:25] "GET / HTTP/1.1" 200 -
MASTER - - [06/Apr/2009 20:44:25] code 404, message File not found
MASTER - - [06/Apr/2009 20:44:25] "GET /favicon.ico HTTP/1.1" 404 -
MASTER - - [06/Apr/2009 20:44:28] code 404, message File not found
MASTER - - [06/Apr/2009 20:44:28] "GET /favicon.ico HTTP/1.1" 404 -

Firefox has also filled up the error log on my Apache servers on normal internet sites where I'm too lazy to upload a favicon.ico.
Comment 11 Tyler Downer [:Tyler] 2010-07-08 22:36:08 PDT
This bug was originally reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.6 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
Comment 12 Tyler Downer [:Tyler] 2010-08-16 21:11:00 PDT
No reply, INCOMPLETE. Please retest with Firefox 3.6.8 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.

Note You need to log in before you can comment on or make changes to this bug.