items dragged and dropped to the toolbars can't be removed

VERIFIED INVALID

Status

()

VERIFIED INVALID
11 years ago
11 years ago

People

(Reporter: football1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

I searched through dozens of Bugzilla posts but still didn't see one that matched my inquiry, so I apologize if this has already been addressed. - -
I customized my toolbar by going to view/toolbars/customize.  I successfully grabbed and dragged several tools to the navigation toolbar. Then I wanted to undo this and clicked the button “standard” (in the customize-window). Now if I view the navigation toolbar, I get a duplicate address and search bar. No way to remove the doublettes! In the contrary, trying to fix the problem by clicking the “standard”-button again, I got now three address and search bars! 
Can anybody help me? Thanks and sorry, my English is not very good. 


Reproducible: Always

Steps to Reproduce:
1.Customize the navigation toolbar with drag and drop.
2.Press "standard" in the customize window to undo. 
3.You get now two buttons "address bar", two "search bar", two "home", two "back" and so on.
4.Press "standard" to undo again.
5.You get now THREE buttons "address bar", THREE "search bar", THREE "home", THREE "back" and so on.
6.Trying remove the triples by hand from the toolbar with drag and drop fails.
Actual Results:  
I've got a very full toolbar with triple tools, the tools very narrow by each other, and some tools disappear at the right side (can't be seen). 

Expected Results:  
I want to be able to remove all tools from the toolbar I don't need.
I tested this with Firefox 2.0.0.9 on Windows XP but couldn't reproduce the problem. Do you also see the problem if you start Firefox in safe-mode, try the option to reset your toolbars and start in normal mode again?
If the problem still shows up go to safe-mode and try disabling all add-ons.
http://kb.mozillazine.org/Safe_Mode_(Firefox)
(Reporter)

Comment 2

11 years ago
Thank you very much, it works! Following your suggestions I found out, that the reason for the bug is in application "DragNDrop Toolbars". When I disabled it, I was able to drag all items from the toolbar I wanted. 
I now leave "DragNDrop Toolbars" disabled and hope that somebody will update that tool so that I can use it again - without bugs. 
By the way, since then I did not know safe mode of Firefox. Learnt a lot! Thanks for that fast help!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Jens, the developers like to reserve FIXED resolution for bugs that had code applied to resolve the problem.  In this case, I think the bug was invalid.
Resolution: FIXED → INVALID
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.