Often crashes if using ctrl+shift+tab - [@ nsEventStateManager::GetPrevDocShell]

RESOLVED DUPLICATE of bug 162283

Status

()

--
critical
RESOLVED DUPLICATE of bug 162283
11 years ago
11 years ago

People

(Reporter: me639241, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

While browsing with many tabs open, and several of them still loading,
navigating to the left tab of the current with ctrl+shift+tab (backward) often results in a crash. This never occours with ctrl+tab (forward navigation to the right tab of the current)

Most likely this is a regression introduced in Firefox 2.0.0.8. (I didn't experience it in 2.0.0.6). It's still there in 2.0.0.9

Reproducible: Sometimes

Steps to Reproduce:
1. Open many tabs, make sure some are still loading
2. Use keyboard navigation to select tab(s) left of the current (ctrl+shift+tab)

Actual Results:  
Crash (happens nearly every session when lots of still loading tabs where open)

Expected Results:  
No crash. Selection of the tab located left of the current.


- Selecting tabs with the mouse never causes crashes!
- Cycling through the tabs forward (ctrl+tab) also never causes crashes!
- Try to cycle through many tabs backward for best crash reproduction.
Not able to reproduce this with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

me639241: Can you supply some additional information to help diagnose this crash?

1) Do you have any extensions installed and if so can you reproduce the crash in Firefox's Safe Mode? If not, which extensions do you have installed?

2) Can you provide a Talkback ID for this crash (most useful)

http://kb.mozillazine.org/Safe_Mode
http://kb.mozillazine.org/Talkback
(Reporter)

Comment 2

11 years ago
Most likely it is an extension. I couldn't reproduce this in safe mode, trying hard. I actually couldn't reproduce it even without safe mode, although I did't invest that much time in it. It seems to be one of those crashes which prefer to occour during normal firefox usage...

My extensions:
Adblock Plus 0.7.5.1
Closy 1.4.0
Full Fullscreen 2.0
Nuke Anything Enhanced 0.54
openselectedlinks2006.01.14
Smart Middle Click 0.5
QuickJava 0.4.2.1
repagination 2006.4.5
Scrapbook 1.2.0.8
Smart Middle Click 0.5
Viamatic foXpose 0.6
(Reporter)

Comment 3

11 years ago
I could trace it down to the Full Fullscreen 2.0 extension!
This bugs only occours with its "hide tab bar" feature enabled.

(I disabled all other extensions)

Steps to reproduce a hang (it may crash if more tabs are open):
1. Install the Full Fullscreen extension
2. In its options enable the middle two, disable the others
3. Make google.com your default homepage (perhaps obsolete)
4. Restart Firefox
5. Open two more tabs with google.com
6. Close the first tab (the one that opened at Firefox startup)
7. Click the last tab
8. Switch to fullscreen by F11
9. Press Ctrl+Shift+Tab
10. Firefox crashes or hangs

Strange that it didn't happen with FF 2.0.0.6; (I refuse further tests!!)
Thanks for narrowing it down, good steps to reproduce there.

Talkback ID: TB38036149
Crash @nsEventStateManager::GetPrevDocShell

-> duplicate of bug 162283

Seems that Full-fullscreen extension isn't the culprit, just makes it more likely to hit the bug.

This has been fixed for Firefox 3 and there was some mention of fixing it in Fx2.

If you'd like to file bug reports for crashes in the future, I really do recommend you install Talkback - it makes it much easier to find the cause of the crash and if it has already been reported.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 162283
(Reporter)

Updated

11 years ago
Summary: Often crashes if using ctrl+shift+tab (this usually selects tabs to the left by keyboard) → Often crashes if using ctrl+shift+tab - [@ nsEventStateManager::GetPrevDocShell]
You need to log in before you can comment on or make changes to this bug.