History sidebar not organized when using 'by site'

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: brianvanderburg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

In the history sidebar, view By Date And Site organizes under the day and then the site in a tree.  view By Date organizes under the day in a tree, but view By Site does not

By Date And Site:

Today
--www.yahoo.com
----URL1
----URL2
--www.google.com
----URL1
----URL2
Yesterday
...

By Date
Today
--www.yahoo.com/...
--www.google.com/...
Yesterday
--www.povray.org/...
--...

By Site DOES NOT do this, which I think it should:
www.google.com
--URL1
--URL2
www.povray.org
--URL1
--URL2

Instead it does this, without creating an organization the way that the sites are organized under the day in view by Date and Site.
www.google.com/...
www.google.com/...
www.povray.org/...
www.povray.org/...


Reproducible: Always

Steps to Reproduce:
1. History->Show In Sidebar
2a. View button in history sidebar->By Date And Site
2b. Notice how it is organized in the tree: day->domain->item
3a. View button in history sidebar->By Site
3b. Notice how it is not organized in a tree lice domain->item, but is just a list of history items.
Actual Results:  
The history list is not in a tree form with branches as the domains and leafs as the actual history item.

Expected Results:  
The history is in a simple list for with

Comment 1

11 years ago
works for me in Firefox 3.0b3 (it's one of the many changes in Firefox 3)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Comment 2

11 years ago
it was done in bug 378632

Updated

11 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks
You need to log in before you can comment on or make changes to this bug.