Alarms show up (many and diff amount of) hours late

VERIFIED DUPLICATE of bug 357706

Status

Calendar
Alarms
--
major
VERIFIED DUPLICATE of bug 357706
10 years ago
10 years ago

People

(Reporter: Ben Lesnak, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Lightning/0.7

I set an alarm to go off at 1pm, it just went off at 7:09pm.  I have all the notification boxes enabled in "options" and the alarms are supposed to go off 15 mins before the event.  They do not.  I had the same problem with version 0.5 too.
This seems like such a fundamental part of a calendar program, but I guess it is not affecting everyone

Reproducible: Always

Steps to Reproduce:
1. Set an event on the calendar
2. Work as normal - nothing happens 15 mins before the event time when the alarm is supposed to pop-up
3.  Continue working as normal - alarm will pop up from 2-6+ hours after the selected time.
Actual Results:  
Alarms never go off at the correct time, ever.

Expected Results:  
Alarms should activate when specified, 15mins before the time of the event

Plain Windows XP configuration, 768mb RAM, Dell Inspiron 700m.  I usually have open Thunderbird and Windows Media Player, and maybe MS Word and Firefox.

Comment 1

10 years ago
Did you created the events in question within Lightning? Or did you imported them from external source e.g. an meeting invitation? Do you see any calendar related messages in the Error Console?

Do you hibernate your Windows system? If yes, do you keep Thunderbird running during that time? (see Bug 357706)
(Reporter)

Comment 2

10 years ago
All events are created within Lightning.  I do not get any error calendar-related error messages.

The machine is a laptop and yes, it does go into hibernation mode with Thunderbird running.  I guess that is the problem.  I just disabled hibernation, hopefully that fixes it.  I saw there was a patch created, but it does not seem to be a user-applicable patch.  Will it be incorporated into the next version?

This problem is a duplicate of 357079 and I marked it as such.

Thanks,
Ben
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 357079
Bug 357079 is for Agenda & Hibernation, but bug 357706 for Alarms & Hibernation.
Duplicate of bug: 357706
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

10 years ago
I disabled hibernation mode - the computer only sleeps now.  
Alarms are still wildly late, same as before.
Is the only way to make this thing work correctly to disable all power saving features?
You need to log in before you can comment on or make changes to this bug.