ASSERTION: Nothing to handle this event!

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: Martijn Wargers (dead), Unassigned)

Tracking

({assertion, testcase})

Trunk
x86
Windows XP
assertion, testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 288471 [details]
testcase

See testcase, when hovering over the document, I get this assertion in current debug trunk build.

Comment 1

9 years ago
I also get this assertion if I Cmd+click a link to a bug and move my mouse over the new tab's content area before the page loads.  It's pretty annoying.

Comment 2

9 years ago
http://mxr.mozilla.org/mozilla-central/source/layout/base/nsPresShell.cpp#5605
I guess we could try to find a target a bit harder - not only targetView = targetView->GetParent(), but also from parent presShell or something like that.
This all would go away, I think, if we had only one view hierarchy (or no views at all).
Anyway, that shouldn't be an assertion, but maybe a warning, if even that.

Comment 3

8 years ago
WFM on Mac using the testcase in comment 0.  I can't reproduce the problem in comment 1 any more, either.

Btw, bug 404798 turned this assertion into a warning.  But I'm not even hitting the warning using the testcase or steps here.

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Comment 4

7 years ago
We already have lots of crashtests like this, so in-testsuite+.
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.