"Del" or "Clear" key should delete cell contents, not entire cells

VERIFIED DUPLICATE of bug 40364

Status

()

P3
normal
VERIFIED DUPLICATE of bug 40364
19 years ago
18 years ago

People

(Reporter: cmanske, Assigned: mozeditor)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
In Del and Clear (on Mac) key handlers, call 
nsITableEditor::GetFirstSelectedCell()
to test if we are in cell selection mode. If it returns an element, call
nsITableEditor::ClearCellContents() so table table structure is not disturbed.
That method *will* delete entire cells only if all the cells in a column or
row are selected.

Comment 1

19 years ago
You filed this bug twice.  If you don't think you did this, we can investigate 
it as a bugzilla bug.  Your second bug has a comment, so I'm marking this as a 
dupe of it.
Also you mention "Mac" does that mean the real bug should be marked All/All?

*** This bug has been marked as a duplicate of 40364 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 2

19 years ago
verified in 5/23 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.