feeditems.rdf is not always updated when feeds and/or posts are deleted ...

RESOLVED DUPLICATE of bug 254230

Status

MailNews Core
Feed Reader
--
minor
RESOLVED DUPLICATE of bug 254230
10 years ago
7 years ago

People

(Reporter: Jean-Michel Reghem, Unassigned)

Tracking

1.8 Branch
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
I've found that feeditems.rdf was more than 1 Mo ... and contains a lot of entry about very old feeds which are no more in my TB (deleted 3 years ago)...

I've deleted the file --> all post was retrieved as new (logical), but now my new rssfeeds.rdf has a size of 11ko ... beter :-)

Maybe there is a problem when we delete some blogs ...

There is also some entries from existing blogs but with deleted entries in TB 
(for example: <RDF:Description RDF:about="http://goffochoco.blogspot.com/2005/08/aujourdhui.html"
                   fz:stored="true"
                   fz:valid="true">
    <fz:feed RDF:resource="http://goffochoco.blogspot.com/atom.xml"/>
  </RDF:Description> )

--> this post is really old ... usually i delete all post after reading and keep no old post ...

--> i've post my feeditems.rdf ... don't know if it can help
(Reporter)

Comment 1

10 years ago
Created attachment 288500 [details]
feeditems.rdf file in zip file
(Reporter)

Comment 2

10 years ago
So, after deleting all new downloaded post in all feeds (i've 79 RSS/atoms feeds), feeditems has a size of 310ko ... but only with references to registered blogs ...

But if i delete a feed, empty the trash, compact the trash (i've deleted http://weblogs.asp.net/molly/atom.aspx ), and close thunderbird... feeditems.rdf stay unchanged, and there is always 5 entries about Molly's blog (the old 5 post i've deleted before deleting the feed)

i don't know how is refresh this file, but in this case i guess there is no delete when a feed is removed
Summary: feeditems.rdf is not updated when feeds are deleted ... → feeditems.rdf is not always updated when feeds and/or posts are deleted ...

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
Version: 2.0 → 1.8 Branch
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 254230
You need to log in before you can comment on or make changes to this bug.