Unable to import ICS file, or accept meeting request, from some Exchange/Outlook attachments

VERIFIED DUPLICATE of bug 392465

Status

Calendar
Import and Export
VERIFIED DUPLICATE of bug 392465
11 years ago
11 years ago

People

(Reporter: tblader, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: Lightning 0.7 (build 2007102303) -- Thunderbird version 2.0.0.6 (20070728)

Trying to Accept a meeting request from Microsoft CDO for Microsoft Exchange occasionally does nothing after selecting a calendar to import the event into. Error console produces the following Exceptions:

Error: [Exception... "'Component not initialized' when calling method: [calIItipItem::clone]"  nsresult: "0xc1f30001 (NS_ERROR_NOT_INITIALIZED)"  location: "JS frame :: file:///home/blah1/.thunderbird/rgcgs2nn.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calItipProcessor.js :: cipPII :: line 109"  data: no]
Source File: file:///home/blah1/.thunderbird/rgcgs2nn.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calItipProcessor.js
Line: 109

Error: [Exception... "'Component not initialized' when calling method: [calIItipItem::clone]"  nsresult: "0xc1f30001 (NS_ERROR_NOT_INITIALIZED)"  location: "JS frame :: file:///home/blah1/.thunderbird/rgcgs2nn.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calItipProcessor.js :: cipPII :: line 109"  data: no]
Source File: file:///home/blah1/.thunderbird/rgcgs2nn.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calItipProcessor.js
Line: 109

Error: uncaught exception: [Exception... "'Component not initialized' when calling method: [calIItipItem::clone]"  nsresult: "0xc1f30001 (NS_ERROR_NOT_INITIALIZED)"  location: "JS frame :: file:///home/blah1/.thunderbird/rgcgs2nn.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calItipProcessor.js :: cipPII :: line 109"  data: no]

Reproducible: Sometimes

Steps to Reproduce:
1. import attached (sanitized) ICS file
2. Asked for calendar to add event to
3. Error console produces Exception errors
Actual Results:  
No email acknowledgment, calendar event, or task was presented entered or created.

Expected Results:  
Email acknowledgment should have opened to reply to meeting request.  Calendar event should have been created.

contents of ICS attachment from Exchange
--8<-----8<-----8<-----8<-----8<-----8<-----8<---
BEGIN:VCALENDAR
METHOD:REQUEST
PRODID:Microsoft CDO for Microsoft Exchange
VERSION:2.0
BEGIN:VTIMEZONE
TZID:GMT -0600 (Standard) / GMT -0500 (Daylight)
BEGIN:STANDARD
DTSTART:16010101T020000
TZOFFSETFROM:-0500
TZOFFSETTO:-0600
RRULE:FREQ=YEARLY;WKST=MO;INTERVAL=1;BYMONTH=11;BYDAY=1SU
END:STANDARD
BEGIN:DAYLIGHT
DTSTART:16010101T020000
TZOFFSETFROM:-0600
TZOFFSETTO:-0500
RRULE:FREQ=YEARLY;WKST=MO;INTERVAL=1;BYMONTH=3;BYDAY=2SU
END:DAYLIGHT
END:VTIMEZONE
BEGIN:VEVENT
X-MICROSOFT-CDO-MODPROPS;X-MODPARAM=1:attendee,BEGIN,class,created,descript
 ion,dtend,dtstamp,dtstart,duration,END,last-modified,location,organizer,pr
 iority,recurrence-id,sequence,status,summary,transp,uid,x-microsoft-cdo-al
 ldayevent,x-microsoft-cdo-apptsequence,x-microsoft-cdo-attendee-critical-c
 hange,x-microsoft-cdo-busystatus,x-microsoft-cdo-importance,x-microsoft-cd
 o-insttype,x-microsoft-cdo-intendedstatus,x-microsoft-cdo-owner-critical-c
 hange,x-microsoft-cdo-ownerapptid
DTSTAMP:20071109T152953Z
DTSTART;TZID="GMT -0600 (Standard) / GMT -0500 (Daylight)":20071112T130000
SUMMARY:Updated: IP Meeting
UID:040000008200E00074C5B7101A82E008000000007073E88D27DEC601000000000000000
 0100000009C9024CA66F754488F4C81837632E83E
ATTENDEE;ROLE=REQ-PARTICIPANT;PARTSTAT=NEEDS-ACTION;X-REPLYTIME=20060922T14
 1700Z;RSVP=TRUE;CN="blah, blah1":MAILTO:blah1@blah.com
ATTENDEE;ROLE=REQ-PARTICIPANT;PARTSTAT=NEEDS-ACTION;X-REPLYTIME=20070312T13
 3600Z;RSVP=TRUE;CN="blah, blah2":MAILTO:blah2@blah.com
ATTENDEE;ROLE=REQ-PARTICIPANT;PARTSTAT=NEEDS-ACTION;X-REPLYTIME=20070312T13
 3906Z;RSVP=TRUE;CN="blah, blah3":MAILTO:blah3@blah.com
ATTENDEE;ROLE=REQ-PARTICIPANT;PARTSTAT=NEEDS-ACTION;X-REPLYTIME=20070312T13
 3749Z;RSVP=TRUE;CN="blah, blah4":MAILTO:blah4@blah.com
ATTENDEE;ROLE=REQ-PARTICIPANT;PARTSTAT=NEEDS-ACTION;X-REPLYTIME=16021022T22
 1800Z;RSVP=TRUE;CN="blah, blah5":MAILTO:blah5@blah.com
ORGANIZER;CN="Blah, Blah":MAILTO:bigblah@blah.com
LOCATION:Blah's Office and Blah will call blah and blah
DTEND;TZID="GMT -0600 (Standard) / GMT -0500 (Daylight)":20071112T140000
DESCRIPTION:Agenda:\N\N
RECURRENCE-ID;TZID="GMT -0600 (Standard) / GMT -0500 (Daylight)":20071113T1
 30000
SEQUENCE:0
PRIORITY:5
CLASS:
CREATED:20071109T152952Z
LAST-MODIFIED:20071109T152952Z
STATUS:CONFIRMED
TRANSP:OPAQUE
X-MICROSOFT-CDO-BUSYSTATUS:BUSY
X-MICROSOFT-CDO-INSTTYPE:3
X-MICROSOFT-CDO-INTENDEDSTATUS:BUSY
X-MICROSOFT-CDO-ALLDAYEVENT:FALSE
X-MICROSOFT-CDO-IMPORTANCE:1
X-MICROSOFT-CDO-OWNERAPPTID:1096194006
X-MICROSOFT-CDO-APPT-SEQUENCE:4
X-MICROSOFT-CDO-ATTENDEE-CRITICAL-CHANGE:20071109T152952Z
X-MICROSOFT-CDO-OWNER-CRITICAL-CHANGE:20071109T152953Z
BEGIN:VALARM
ACTION:DISPLAY
DESCRIPTION:REMINDER
TRIGGER;RELATED=START:-PT00H15M00S
END:VALARM
END:VEVENT
END:VCALENDAR
--8<-----8<-----8<-----8<-----8<-----8<-----8<---
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 392465
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.