Closed Bug 403686 Opened 13 years ago Closed 7 years ago

Search plugins get multi-selected when selecting them quickly

Categories

(Firefox :: Search, defect)

PowerPC
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: tchung, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.8) Gecko/20071004 Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.8) Gecko/20071004 Firefox/2.0.0.8

Able to multi-select plugins when moving them up and down the search plugin window.  

Reproducible: Sometimes

Steps to Reproduce:
1. Launch Fx3 beta 1
2. goto search plugin window in upper right hand corner
3. click on the Arrow > "Manage Search Engines"
4. chose a plugin, and move it up and down.  
5. To generate a repro, you may need to select a few plugins at a time.  The trick is to look for a gray highlight on a different plugin, above the plugin you chose...  then stop there, and click another Unhighlighted plugin
6. Verify you can multi-select different plugins at this point.

* See screenshot
Actual Results:  
Multi highlighted plugins

Expected Results:  
no highlighted plugins
I can't seem to reproduce... does the number of plugins matter? What happens when you click one of the buttons? Does it only affect the last-selected plugin, or does it fail?
I can repro this on a clean profile, with even 2 plugins listed.  here's another screenshot.

looks like moving up and down doesnt matter.  i can repro it just be quickly selecting the plugins with my mouse.  the highlights remain highlighted until clicking the plugin again to cancel out the highlight.

Changing title to reflect this change.
Summary: Search plugins get multi-selected when moving up and down list → Search plugins get multi-selected when selecting them quickly
Attached image Screenshot 2
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.