Closed Bug 403743 Opened 14 years ago Closed 14 years ago

Bookmark toolbar items don't show up even though they are accessible in the Bookmark Toolbar Folder

Categories

(Firefox :: Toolbars and Customization, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 403854

People

(Reporter: rudigens, Unassigned)

References

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1

Error: uncaught exception: [Exception... "'[JavaScript Error: "this._result has no properties" {file: "chrome://browser/content/places/toolbar.xml" line: 357}]' when calling method: [nsIController::isCommandEnabled]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://browser/content/places/controller.js :: updatePlacesCommand :: line 1644"  data: yes]

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Developers are probably going to want some more information. Steps to reproduce, does it happen first start/every start/intermittently, did you do any toolbar customizing, that sort of thing.

Then again, not being a dev, I could be wrong.

In any case, WFM (no missing toolbar items) in normal use on Win server 2003.
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9b2pre) Gecko/2007111409 Minefield/3.0b2pre - Build ID: 2007111409
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Sorry.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Duplicate of this bug: 403747
As I mentioned in 403747, I saw this same problem with this build:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007111404
Minefield/3.0b2pre ID:2007111404

as soon as I did the nightly update and restarted.  This morning, I updated to today's build (2007111505 I think), and it didn't fix it.  So I went back a day by downloading the tar.bz2 from FTP and my bookmarks toolbar is showing up again.  Here's my full build ID:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007111304 Minefield/3.0b2pre ID:2007111304

That should narrow it down pretty well.

Some more details:
* It started happening as soon as I restarted into the 2007-11-14 build for the first time.
* There was never anything in my bookmarks toolbar.  Not intermittent.  Constant.
* None of my bookmarks or history or anything related to Places were ever lost as far as I could tell.  Everything's still there.
* The bookmarks sidebar still worked perfectly.
* I never saw the uncaught exception in the original bug description.  Do I need to flip some config option to get chrome errors in my Error Console?
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
This may be a regression caused by the patch for Bug 400327. The patch for that bug was backed out for the 20071114 11:26 build (http://hourly-archive.localgho.st/win32/20071114_1126_firefox-3.0b2pre.en-US.win32.zip) and the bookmarks worked there. It later re-landed and the problem has reappeared in the 2007111505 nightly build.
Someone with more familiarity with the code than me could say if this is relevant, but I don't have a search bar in my toolbar.
Looks like we have a winner.  In 2007111504, I've added a search bar, and the bookmarks show up again (after a restart).
Same result here. With a search bar I see the bookmarks, removing the search bar again hides the bookmarks.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b2pre) Gecko/2007111505 Minefield/3.0b2pre
moving to toolbars, since it's not related to places backend but due to a toolbars check-in. this feels like a regression.
Component: Places → Toolbars
Keywords: regression
QA Contact: places → toolbars
This is probably a duplicate of bug 403854.
Status: NEW → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 403854
You need to log in before you can comment on or make changes to this bug.