Iframe does not show contents if content length exceed 32767.

RESOLVED DUPLICATE of bug 333994

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 333994
10 years ago
9 years ago

People

(Reporter: SharathChandra, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

I have two large Iframes in my main page.With content length of one of the Iframe exceeding upto 50000px.When height of the Iframe is more than 32767 say 50000px.It will only use the space till 32767 adding a scrollbar to browse through the extra content,leaving the extra space as blank.If scrollbar is disabled for Iframe then there is no way to browse through the extra content.

If I enable scrollbar option for Iframe then I end up having two scrollbar's one for main page and other for Iframe which looks bad.If I disable scrolling for Iframe,then the contents are truncated.

In both the cases extra length after 32767 is left blank.

Problem is only seen on Windows platform.Problem is not seen when using Firefox on Solaris platform.

Reproducible: Always

Steps to Reproduce:
1.Main.html
-------------
<html><head>
</head>
<body>
<iframe name="first" width="100%" style="height:50000" src="first.html" scrolling='no' ></iframe>
<iframe name="second" width="100%" src="second.html"></iframe>
</body></html>
-----------------
2.Make sure content length of first.html is more than 32767.
3.


Expected Results:  
Iframe should be showing the content in the complete length available instead of limiting it to 32767.

Problem is only seen on Windows platform.Problem is not seen when using Firefox on Solaris platform.
(Reporter)

Comment 1

10 years ago
Created attachment 288650 [details]
Main page containing two Iframes.
(Reporter)

Comment 2

10 years ago
Created attachment 288651 [details]
First Iframe with content length exceeding 32767
(Reporter)

Comment 3

10 years ago
Created attachment 288652 [details]
Second IFrame
(Reporter)

Updated

10 years ago
Attachment #288650 - Attachment mime type: text/html → text/plain
(Reporter)

Updated

10 years ago
Attachment #288651 - Attachment mime type: text/html → text/plain
(Reporter)

Updated

10 years ago
Attachment #288652 - Attachment mime type: text/html → text/plain
Gecko can not handle elements with coordinates exceeding the 16bit boundary very well. So I believe this is a duplicate of bug 215055.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 215055
See Bug 333994 comment 8
Duplicate of bug: 333994
You need to log in before you can comment on or make changes to this bug.