when using the jar protocol with "Show blank page" setting for startup you lose page back and forward functionality

RESOLVED INVALID

Status

()

Firefox
File Handling
--
major
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: ododos, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

I have many bookmarks of local zip files containing manuals with hundreds of html pages that I cannot afford to extract to the filesystem. I use the jar:file: protocol to navigate into the zip file as if it was extracted. I have noticed that if you have set firefox to "Show blank page" at startup the page back and page forward functionality ignores any navigation history.

Reproducible: Always

Steps to Reproduce:
1. Options -> Main -> Startup -> When Firefox starts: -> Show blank page
2. Enter an address of the form jar:file: pointing to a zip file with html pages
3. Navigate through the pages

Actual Results:  
Your navigations gestures aren't kept through the forward and back buttons

Expected Results:  
Your navigations gestures aren kept through the forward and back buttons

This problem appears only when you set Options -> Main -> Startup -> When Firefox starts: -> Show blank page. There was an earlier version (I think 1.5) that this problem didn't exist.
"A zip file with html pages" e.g. the bookmarks.html file?
With bookmarks in a zip file, navigating through the bookmarks I can't reproduce the problem neither in Firefox 2 nor in Firefox 3 on Windows XP.
Did you also test this in -safe-mode? http://kb.mozillazine.org/Safe_Mode_(Firefox)
(Reporter)

Comment 2

11 years ago
I disabled all the add-ons one by one. Apparently the problem is caused by Googlebar lite (4.6.3) and I will report it there.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.