bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[10.5] Extra file menus appear in the menu bar (multiple file menus)

VERIFIED FIXED

Status

()

Core
Widget: Cocoa
P1
normal
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: Gavin, Assigned: Josh Aas)

Tracking

Trunk
x86
Mac OS X
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Created attachment 288897 [details]
screenshot

Since the patch for bug 385966 landed, I now see multiple file menus in certain cases. cbarrett has STR, I noticed it when I woke my laptop from sleep.

This screenshot is from the latest Mac nightly on Leopard.
[15 14:39:14] <cbarrett_work> gavin|: oh I just repro'd
[15 14:40:48] <cbarrett_work> 1. new window 2. cause a sheet to appear (go to intranet.mozilla.org) 3. dismiss sheet 4. close window. 5. open window.
Flags: blocking1.9?
(Assignee)

Comment 2

11 years ago
Created attachment 288912 [details] [diff] [review]
fix v1.0

Forgot that we have app menu shenanigans going on in our top-level window code to deal with menubarless windows. Reviewer, please re-test all known repro steps.
Attachment #288912 - Flags: review?(cbarrett)
Attachment #288912 - Flags: review?(cbarrett) → review+
(Assignee)

Updated

11 years ago
Attachment #288912 - Flags: superreview?(roc)
(Assignee)

Updated

11 years ago
Flags: blocking1.9? → blocking1.9+
Priority: -- → P1
Attachment #288912 - Flags: superreview?(roc) → superreview+
(Assignee)

Comment 3

11 years ago
landed on trunk
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Assignee)

Updated

11 years ago
Duplicate of this bug: 403908
verified fixed using Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O 10.5; en-US; rv:1.9b2pre) Gecko/2007120304 Minefield/3.0b2pre.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.