Content-Type: multipart boundary is removed when XMLHttprequest is sent

RESOLVED DUPLICATE of bug 393968

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 393968
11 years ago
11 years ago

People

(Reporter: Kris, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: 0.8

When a XmlHttprequest is created and the content-type is set to 

multipart/form-data; boundary=45309FFF-BD65-4d50-99C9-36986896A96F

it is replaced with the following:

multipart/form-data;charset=UTF-8

This causes the web server to return the error: Error in file upload: the request was rejected because no multipart boundary was found




Reproducible: Always

Steps to Reproduce:
1.Start Prism with a web page that contains a javascript to create the XmlHttpRequest
2.setRequestHeader('Content-Type',"multipart/form-data; boundary=45309FFF-BD65-4d50-99C9-36986896A96F"); }
3.Create a content containing the form-data strings
4.send the XmlHttpRequest
Actual Results:  
The Header of the request send is changed into:

Content-Type: multipart/form-data;charset=UTF-8

Expected Results:  
What happens in FF2.0.0.9 browser with the same web page/javascript the header contains:

Content-Type: multipart/form-data; boundary=45309FFF-BD65-4d50-99C9-36986896A96F
Prism doesn't do anything differently than Minefield/Firefox, it's just got a newer Gecko.
Component: Prism → DOM
Product: Mozilla Labs → Core
QA Contact: prism → general
(Reporter)

Updated

11 years ago
Component: DOM → JavaScript Engine
Component: JavaScript Engine → DOM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 393968
You need to log in before you can comment on or make changes to this bug.