After Browser started and first tab is closed no tab has focus

VERIFIED WORKSFORME

Status

()

Firefox
Tabbed Browser
VERIFIED WORKSFORME
11 years ago
8 years ago

People

(Reporter: JackDMF, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [session-store-testday])

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007111505 Minefield/3.0b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007111505 Minefield/3.0b2pre

After I start the Browser and the Homepage is opened I close this tab.
The only left tab then is the default about:blank tab. But the weird thing is, that this tab has not the focus.
Same happens if I open another tab in background, before closing the homepage, and then close the homepage tab. Then the new tab is displayed (the content) but has not got the focus (visible in the tab bar).
Also in both cases the address bar does not reflect the now correct address, it still shows the address of the closed tab.

This behaviour only happens in FF3/Minefield.

Reproducible: Sometimes

Steps to Reproduce:
1.Open Browser
2.Close Homepage

-OR-
1.Open Browser
2.Open Page in Background Tab
3.Close Homepage
Actual Results:  
The tab, that should be active has not the focus in the tab bar.
Also the address in the address bar is not correct, but the old address of the closed tab.
The content display is correct (page, which was loaded is shown in the content area)

Expected Results:  
Tab bar should activate the a) empty tab or b) the background tab, that now came to be the foreground tab.
And the address bar should display the correct address of the now active tab.

Using: Minefield 3.0b2 pre 2007111505
Default theme.
Addons:
Adblock plus 0.7.5.3
Adblock plus element hiding helper 1.0.2
Gmail notifier 0.6.2.2
Gmarks 0.9.7.2
Nightly Tester Tools 1.3b3
(Reporter)

Comment 1

11 years ago
Created attachment 288982 [details]
Screenshot of the given error

Did some research and found this additional hints:
1. My homepage is (as can be seen) a https-site
2. the homepage is a redirection from another address (not https)

This bug always occurs if you open that page and close it.
With other homepages I could not reproduce the bug.
(Reporter)

Comment 2

11 years ago
Correction: Redirection comes from another https-site.
Hope those information helps to find the reason of the bug.
If you got any questions, feel free to ask me.
(Reporter)

Updated

11 years ago
Flags: blocking-firefox3?
We need to get this confirmed before we can accept it as a blocker nom:

Johnath, can you dedicate a couple of cycles to looking at this?

Jack: can you reproduce in safe-mode?
Flags: blocking-firefox3?
I've had a look, and I can't reproduce this problem.  Obviously I don't dispute the screenshot, but it's also hard to make progress without a way to reproduce it.  Here's what I've tried:

- Homepage: default, https://www.paypal.com, http://www.paypal.com (redirects to https, but not sure why this should matter)
- Platform: Mac, Vista
- Existing profile, new profile, new profile with listed addons
- Closing tab with keyboard vs. mouseclick
- tab bar persist on and off

Jack, if you can consistently reproduce this, can you open about:config and, if you haven't already done so, change

  javascript.options.showInConsole

to true?  Then after it happens, can you look in the error console for any errors or warnings being logged which aren't related to the page itself?
(Reporter)

Comment 5

11 years ago
Mike: Yes I can reproduce that in safe-mode.

Johnathan: I've turned on that option and it gives me loads of CSS errors (related to site obviously) and one "content is null" chrome://browser/content/browser.js
and an information saying "SessionStore: TypeError: aWindow.getBrowser().currentURI is undefined"
there's not such a line (anymore?) in browser.js and i cannot reproduce with given STRs.

so this is likely WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008030206 Firefox/3.0.0.0 ID:2008030206 ...
Version: unspecified → Trunk
(Reporter)

Comment 7

10 years ago
I still can reproduce this error with nightly build 2008030305.

But there is a new error in the console:
"content is null" still is there and a new:
"this.mCurrentBrowser is null" -> chrome://browser/content/tabbrowser.xml

Comment 8

8 years ago
It's been over two years, can this still be reproduced? I can't get the behavior on 3.6 or 4Beta8.

If you can still reproduce it, what extensions are you using and what tab-related preferences have you tweaked?
Whiteboard: [session-store-testday]
Resolving WORKSFORME, please reopen if this is still an issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 10

8 years ago
I cannot confirm, if this still happens since i do not have access to the same setup as back then anymore and more importantly cannot access that particular site that caused the problems anymore.
Based on comment 10, marking verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.