ma.gnolia.com using prototype.js, which conflicts with Firefox 3 implementation of getElementsByClassName

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
11 years ago
4 years ago

People

(Reporter: deb, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

http://ma.gnolia.com -- You'll have to create an account and log in to see the issue.  The menus in question are the "Home | You | Contacts | Groups | Discover | Help" menus along the top of the user page.

In Fx2 all but the "Home" menu display a drop menu when clicked.  In Fx3 none display a drop menu when clicked.  This essentially breaks the majority of the site's functionality, since most pages cannot be accessed without those menus.
Deb: Can you please paste the user agent in - need to know if you are running the beta or trunk nightly.
(Reporter)

Comment 2

11 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b2pre) Gecko/2007111604 Minefield/3.0b2pre

This works in Safari on 10.5 but does not work on 10.4 using the latest trunk nightly, so it is not a problem confined to 10.5.1.

Comment 4

11 years ago
Please make a testcase if you can.
Severity: critical → major
Can you reproduce with a locally-saved (web page, complete) copy?  that'll make it easier to poke at.  Thanks!
Looks like getElementsByClassName prototype damage; updated prototype library should fix it (affects Safari 3.1 as well, I predict).
(In reply to comment #6)
> Looks like getElementsByClassName prototype damage; updated prototype library
> should fix it (affects Safari 3.1 as well, I predict).

Yeah, picking up on Shaver's point, clicking the menus gives me:

Error: $("navigation").getElementsByClassName("context-menu").each is not a function
Source File: http://gnolia.cachefly.net/javascripts/omni.js?1205276626
Line: 7823

and 

Error: document.getElementsByClassName("help_icon").each is not a function
Source File: http://gnolia.cachefly.net/javascripts/omni.js?1205276626
Line: 7830

Created attachment 311390 [details]
complete webpage (zip)

The code they're using to do the drop downs is:

	<li class="context-menu">
		<a href="http://ma.gnolia.com/people" title="Contacts"><span>Contacts</span></a>
		<div class="hidden">
		<ul class="first">
	
		<li><a href="http://ma.gnolia.com/people/beltzner/contacts/bookmarks" title="Latest Bookmarks">Latest&nbsp;Bookmarks</a></li>                   
	
		<li><a href="http://ma.gnolia.com/people/beltzner/contacts/tags" title="Top Tags">Top&nbsp;Tags</a></li>                   
	
		<li><a href="http://ma.gnolia.com/people/beltzner/contacts" title="Your Contacts">Your&nbsp;Contacts</a></li>                   
	
</ul>

I didn't have time to look into the CSS or JS, but they're in the attached ZIP file.
Assignee: nobody → english-us
Component: General → English US
Product: Firefox → Tech Evangelism
QA Contact: general → english-us
Summary: Ajax drop menus at ma.gnolia.com do not work in Fx3, are fine in Fx2 → ma.gnolia.com using prototype.js, which conflicts with Firefox 3 implementation of getElementsByClassName
Target Milestone: --- → Apr
Version: Trunk → unspecified
This is a result of the site using prototype.js, which has a non-spec-compliant version of getElementsByClassName and needs to be updated.

--> Tech Evang
--> Hardware: All
--> OS: All
OS: Mac OS X → All
Hardware: Macintosh → All
Magnolia is RIP since January 30, 2009.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Component: English US → Desktop
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.