Group mailing feature request

RESOLVED DUPLICATE of bug 75711

Status

--
enhancement
RESOLVED DUPLICATE of bug 75711
11 years ago
11 years ago

People

(Reporter: paul, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: 

I would like to see an additional text field in the property sheet for any addressee, preferably on the Contact page, which would allow me to enter a list of keywords separated by commas (or some equivalent entry method). I might use words like "Friends", "Eclipse", "Java", "Audio", "Standards" - could be anything.

Then, when I prepare to post an email, in the To: and/or Cc: fields, I could enter one or more keywords (say, preceded by a dollar sign to identify them as keywords) and, thereby send the email to all respondents having the keywords I specified. This would minimize restrictions on me while maximizing my capabilities in a very simple and contextual way.

Of course, I am talking about sets of respondents, so the ability to specify union, intersection, or difference would be useful, but would complicate. Maybe use of +, * and - operators would be optional, but with a default of + (probably).

A follow-up dialog might be appropriate showing the resultant list(s) of addressees so that I could reject some.

Or maybe some simpler version of this. At least some simple way to create groups which may overlap, which the keyword approach provides easily. If I knew the code, I would be happy to write it myself, it would be a fun little sub-project. Alas, I don't.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 75711
You need to log in before you can comment on or make changes to this bug.