Closed Bug 404056 Opened 12 years ago Closed 12 years ago

Select Calendar dialog is empty during export/import/publish

Categories

(Calendar :: General, defect)

Mozilla 1.8 Branch
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: sebo.moz)

References

Details

(Keywords: regression)

Attachments

(1 file)

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.10pre) Gecko/20071116 Calendar/0.8pre

Select Calendar dialog is empty during export/import/publish.

Steps To Reproduce:
1. Start Sunbird with clean profile.
2. Create a second local calendar.
3. Select File -> Export Calendar, File -> Import or File -> Publish Calendar

Actual Results:
Select Calendar dialog is displayed but empty. No error messages in Console.

Expected Results:
Existing (and writable) calendars are displayed in the Select Calendar dialog.
Hmm, on TRUNK everything is OK:
    Works in Sunbird 0.6a1 (2007-11-16-06)

Regression range for MOZILLA_1_8_BRANCH:
    Works in Sunbird 0.8pre (2007-10-27-05)
    Fails in Sunbird 0.8pre (2007-10-28-06)

Checkins during regression range on MOZILLA_1_8_BRANCH:
    http://tinyurl.com/2e3ob3
    
The calendars are actually in the list but not displayed. If you click into the list field and use the keyboards up and down arrows keys to navigate the list the entries get visible.
Duplicate of this bug: 404178
I've confirmed this, the calendars are in the list, but are not viewable.  If you arrow up, they become visible.
Philipp, this seems to be caused by your patch from bug 390508. But the different behavior on Mozilla1.8 and Trunk is weird.
Flags: blocking-calendar0.8?
The behavior is kinda weird: If I have 2 local calendars the list is empty. But if I have 3 local calendars they are shown again (Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.10pre) Gecko/20071127 Calendar/0.8pre)
Duplicate of this bug: 405945
OS: Windows 2000 → All
Hardware: PC → All
Flags: blocking-calendar0.8? → blocking-calendar0.8+
I've confirmed Stefan's comments, a third entry makes the list visible again, intermittently.
This is indeed caused by the changes from Bug 390508 and the attempt to preselect the calendar in the list. If I remove the two lines at http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/calendar/base/content/chooseCalendarDialog.xul&rev=1.4&mark=89-90#84 it works again. 

I played around with this and tried to find a solution for the problem but nothing really seemed to work. Either the entire list was invisible or the default entry was not selectable or too little entries were displayed or everything was ok - dependent on what calendar was selected in Sunbird.

My suggestion: Remove this two lines and restore the 0.7 behavior to fix it.
Blocks: 390508
Duplicate of this bug: 410516
Attached patch fixSplinter Review
Moving code around seemed to work for me. I don't understand the reason, honestly. It looks like the vbox needs to be build before the listbox can be modified. Inserting alerts in the code also helped - so there are likely some race conditions.
Assignee: nobody → sebo.moz
Status: NEW → ASSIGNED
Attachment #295639 - Flags: review?(philipp)
Comment on attachment 295639 [details] [diff] [review]
fix

This seems to fix the issue, r=philipp
Attachment #295639 - Flags: review?(philipp) → review+
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.8
Verified using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12pre) Gecko/2008011712 Calendar/0.8pre.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.