Closed Bug 404074 Opened 12 years ago Closed 12 years ago

Clear Private Data Menu is cut off in french firefox 3 beta 1

Categories

(Mozilla Localizations :: fr / French, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: cbook, Assigned: bugzilla.fr)

References

Details

Attachments

(1 file)

found by livrerie on the beta 1 testday:

Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1

The Clear Private Data Menu is cutoff, see screenshot
Flags: blocking-firefox3?
Attached image cut off menu
I see two ways of fixing this:

In window.width, http://bonsai-l10n.mozilla.org/cvsblame.cgi?file=/l10n/fr/browser/chrome/browser/sanitize.dtd&rev=1.10&mark=22, beaf up the width so that you don't get any line wraps (which is the problem here, I guess), or, make the width include a height, as it's included as

style="width: &window.width;;"

in sanitize.xul.

http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/browser/base/content/sanitize.xul&rev=1.15&mark=55#50

Might be worth filing a bug on the actual layout issue, that prefwindow assumes that lines don't wrap.
I've both enlarged the dialog by 5em and shortened the label of the third checkbox. Even if the window was high enough, I don't think a wrapped line next to a checkbox is nice.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Duplicate of this bug: 404733
Duplicate of this bug: 405292
Flags: blocking-firefox3?
Flags: blocking-firefox3?
Sorry, I forgot to make this bug verified fixed (Windows XP SP2).
Status: RESOLVED → VERIFIED
Blocks: 414803
Depends on: 425368
No longer depends on: 425368
Flags: blocking-firefox3?
You need to log in before you can comment on or make changes to this bug.