Closed Bug 404084 Opened 12 years ago Closed 12 years ago

Rename "Organize Bookmarks" menu item

Categories

(Firefox :: Bookmarks & History, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Firefox 3 beta2

People

(Reporter: faaborg, Assigned: beltzner)

References

Details

(Keywords: polish)

Attachments

(1 file, 1 obsolete file)

We need to rename the Organize Bookmarks menu item to "Show all Bookmarks" to address a usability issue created by the star interface.

Single clicking on the star will produce a small contextual dialog saying "Page Bookmarked" but to streamline the interface, it will not say where the bookmark was placed.  Also, so we don't bloat the user's toolbar or menu, we are placing these bookmarks in the "Unfiled Bookmarks" folder, which is not accessible through primary UI.  We made these decisions to enable user's to easily bookmark thousands of pages.

However, after seeing the "Page Bookmarked" notification many times, user's may eventually wonder "where are all these bookmarks anyway, I don't see them in my menu or toolbar?"  So for that situation, I think it is important that the bookmarks menu item for displaying the Bookmarks and History window be renamed to reference their confusion.

User: "Where are all my bookmarks?"
Menu item: "Show all Bookmarks"
Flags: blocking-firefox3?
Blocks: 393514
Assignee: nobody → mano
Depends on: 387746
Priority: -- → P2
Target Milestone: --- → Firefox 3 M10
It should be "Show Bookmarks & History...", I think
Flags: blocking-firefox3? → blocking-firefox3+
Priority: P2 → P3
>It should be "Show Bookmarks & History...", I think

That won't work as well in the confused user task flow.  Also talking about history at the top of the bookmarks menu is odd.  I think we should consider a "show all history" menu item to mirror the "show all bookmarks" item over in the history menu.
Agreed. Patch coming.
Changes the label, revs the entity name and updates the reference in the menubar set. I left the keyboard shortcut name as manBookmarkKb, lemme know if I should change that, too.
Attachment #289823 - Flags: review?(mano)
Also, while I'm thinking of it, it would be nice to modify the
"Browser:ShowBookmarks" command so that it brings up the Places Organizer with
"All Bookmarks" in focus. I filed bug 404991 for that.
Comment on attachment 289823 [details] [diff] [review]
renames "Organize Bookmarks..." to "Show All Bookmarks..."

>Index: browser/locales/en-US/chrome/browser/browser.dtd
>===================================================================
>RCS file: /cvsroot/mozilla/browser/locales/en-US/chrome/browser/browser.dtd,v
>retrieving revision 1.76
>diff -u -8 -p -r1.76 browser.dtd
>--- browser/locales/en-US/chrome/browser/browser.dtd	25 Oct 2007 23:02:20 -0000	1.76
>+++ browser/locales/en-US/chrome/browser/browser.dtd	22 Nov 2007 15:27:47 -0000
>@@ -56,18 +56,18 @@
> <!ENTITY bookmarksMenu.label "Bookmarks">
> <!ENTITY bookmarksMenu.accesskey "B">
> <!ENTITY addCurPageAsCmd.label "Bookmark This Page...">
> <!ENTITY addCurPageAsCmd.commandkey "d">
> <!ENTITY subscribeToPageMenupopup.label "Subscribe to This Page">
> <!ENTITY subscribeToPageMenuitem.label "Subscribe to This Page...">
> <!ENTITY addCurPagesCmd.label "Bookmark All Tabs...">
> <!ENTITY addCurPagesCmd.accesskey "T">
>-<!ENTITY manBookmarksCmd.label "Organize Bookmarks...">
>-<!ENTITY manBookmarksCmd.accesskey "M">
>+<!ENTITY showBookmarksCmd.label "Show All Bookmarks...">
>+<!ENTITY showBookmarksCmd.accesskey "M">

For accessibility reasons, accesskeys in the bookmarks menu are not set, and this line should rather be removed.

Please also remove addCurPagesCmd.accesskey while you're here.

r=mano otherwise.
Attachment #289823 - Flags: review?(mano) → review+
Mike: don't we already do what you've suggested in comment 5?
Mano: quite right, we do, Proto just doesn't reflect the "selected but not focused" state in the left hand sidebar (I'll mention that in the mac theme bug).

This patch addresses your comments.
Attachment #289823 - Attachment is obsolete: true
Comment on attachment 289826 [details] [diff] [review]
renames "Organize Bookmarks..." to "Show All Bookmarks..." (mano's comments addressed)

(carrying over r+)
Attachment #289826 - Flags: review+
Checking in browser/base/content/browser-menubar.inc;
/cvsroot/mozilla/browser/base/content/browser-menubar.inc,v  <--  browser-menubar.inc
new revision: 1.119; previous revision: 1.118
done
Checking in browser/locales/en-US/chrome/browser/browser.dtd;
/cvsroot/mozilla/browser/locales/en-US/chrome/browser/browser.dtd,v  <--  browser.dtd
new revision: 1.77; previous revision: 1.76
done
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Assignee: mano → beltzner
Keywords: checkin-needed
I think you guys are making a big mistake here by renaming the option to something that is way too ambiguous and confusing.  People are going to completely overlook that option when they are trying to find what is now called the Places Organizer.  The option could just be named "Places Organizer", but even better than that, since it is located in the Bookmarks menu, why don't we just call it "Manage Bookmarks"?  Nobody knows what the Places Organizer even is, but they know what "Manage Bookmarks" means.

So, you name it "Manage Bookmarks", and a random user comes along and wants to manage his bookmarks.  He goes to the Bookmarks menu, and sees the option "Manage Bookmarks".  "Ah yes!" he proclaims, "What great user design this browser has!  That is exactly what I came here to do."  And so he clicks on it, and it opens up the Places Organizer.  He notices that this window that just opened is called the "Places Organizer", and he realizes that that is a pretty nifty window, because not only can it be used for managing his bookmarks, but it can be used to manage much more than that! He also notices that there is an "Unfiled bookmarks" folder contained within it, something that he doesn't remember seeing on the Bookmarks menu.  "Wow!" he exclaims, "there is this neat hidden folder in here where bookmarks that have been starred but have not been filed go!  This is kind of like limbo, the place where bookmarks that haven't been baptized go!"  

My point is that just because the "Unfiled bookmarks" folder isn't visible in the Bookmarks menu should NOT be the basis for the naming of this particular menu option.  

It would be like calling a link to Amazon.com "show all books", a link to Google.com "show all websites", a link to Windows Explorer "show all files", or a link to the iTunes app "show all music".

And, it actually DOESN'T "show"..."all"...bookmarks in any traditional UI sense of the word "show" or "all".  What it does is bring up a window to manage bookmarks and other places entries, which happens to contain as one of its "features" the hidden "Unfiled bookmarks" folder.

For that matter, why not just unhide the silly "Unfiled bookmarks" folder in the first place, and that way there is no need to obfuscate the interface based on any of this!


The word "show" generally refers, in user interfaces, to displaying something WITHIN the current context, not opening a whole new window. "Show all bookmarks" sounds either like a boolean option that would be checked if all hidden bookmarks were shown, and unchecked if they weren't, or it sounds like a link that would bring up a list of all bookmarks in one big list.  You can not clearly infer from it that it means to bring up a Bookmarks Organizer.
verified with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b2pre) Gecko/2007112604 Minefield/3.0b2pre
Status: RESOLVED → VERIFIED
>why don't we just call it "Manage Bookmarks"?

-We don't think that a large percentage of users actually manage their bookmarks, usually they are pretty unorganized.  We believe that it is more likely the user is looking for something in particular, like a bookmark they starred but didn't file to a particular folder, an item out of history, or all the pages that match a certain set of tags.  None of those use cases really fit the task of "managing" bookmarks.

-We potentially want to store a lot of other data in the Library in the future (like purchase receipts, and data pulled out of microformats), so we needed a name that would scale to things beyond bookmarks (already we have bookmarks, history, tags and possibly downloads).

>It would be like calling a link to Amazon.com "show all books", a link to
>Google.com "show all websites", a link to Windows Explorer "show all files", or
>a link to the iTunes app "show all music"

Actually I think those links are pretty descriptive :)

>For that matter, why not just unhide the silly "Unfiled bookmarks" folder in
>the first place, and that way there is no need to obfuscate the interface based
>on any of this!

Here is are rational for not doing this

-Hitting the star is easy (by design), so users may end up with 2000 or 3000 unfiled bookmarks.  This is great in terms of searching against the places database, but obviously can't scale to a browse-based UI like a folder on the bookmarks toolbar, both in terms of usability and literally populating a with that many items.

-If users see a huge list of bookmarks growing they may feel like they need to manage the mess, instead of just searching against it.  If they do take a bunch of time to file away all of the unfiled bookmarks, they may think to themselves "that took forever and wasn't very fun, I need to bookmark less pages so I don't have a such a queue of unorganized stuff in the future."  If that feeling results in the user bookmarking fewer pages, than we have defeated the original goal of making bookmarking light weight, easy, and faster than just searching google for what you are looking for (which is what most people do instead of bookmarking pages).
I strongly agree with Comment 11. But the basis of choosing shouldn't be the most "clever" argument presetned here-- it SHOULD be the simple fact that even relatively sophisticated nightly testers are being confused and getting lost-- just take a short look at all the posts in the mozillazine "The official xxxxxx build is out topics of the last few days."

It's REALLY not helpful to make hundreds of thousands (millions?) of LESS Adventurous users suffer the same confusion, AT THE SAME TIME they're trying to learn all the other UI changes from FF2 (including many changes which HAVE been needed). Please change it back to the "manage bookmarks" everyone is used to. It's not the meaning of the word, it's the familiarity.

How about "show/manage bookmarks" ????  
>relatively sophisticated nightly testers

Not exactly a mainstream demographic. I realize breaking consistency is bad, but so few users have actually opened the bookmarks organizer in Firefox 2 (or even bookmarked a page), that I don't think the consistency issue will spread to the millions of less adventurous users.  The command "show all bookmarks" solves a very real usability problem with our new light weight bookmarking interface (where the heck are my bookmarks?).  We believe the number of user's who may experience this problem will greatly exceed the number of users who are confused over the terminology change, which is why we are breaking consistency.
Then I'd just call it "Search bookmarks".  As you said above, the Places Organizer is going to do more than just deal with bookmarks, but as you are already doing, it should be named for what the user is going to do from the Bookmarks menu perspective.  "Search bookmarks" can mean to actually search them using the search feature, or it can mean to traverse them by hand.  The new search features make this a no-brainer.  "Search bookmarks" implies that they can find all of their bookmarks.
> We believe that it is more likely the user is looking for something in
> particular, [...]

You mean like how to import their bookmarks?

> None of those use cases really fit the task of "managing" bookmarks.

I'd hope that you would agree that importing bookmarks is something that fits under the topic of "managing" but certainly doesn't fit under the topic of "Show All" (or "search", for that matter). 

Why create needless end-user confusion by hiding useful functions under non-intuitive menu labels?

>I'd hope that you would agree that importing bookmarks is something that fits
>under the topic of "managing" but certainly doesn't fit under the topic of
>"Show All" (or "search", for that matter).

Yeah, I totally agree with that, but thankfully we have File > Import as a more direct path for user's who have the goal of importing bookmarks and are in the main window.

>Why create needless end-user confusion by hiding useful functions under
>non-intuitive menu labels?

The labels will be non-intuitive if they don't mesh with the user's goals.  I believe the most dominant goal from the bookmarks menu will be "I want to see all my bookmarks."  A dominant goal from the history menu will be "I want to see all my history", and a dominant goal from the downloads manager will be "I want to see my download history" (although this got cut for 3).  The idea is that all of these paths will lead to various parts of the library window.

However, you are certainly right that "Show all bookmarks" doesn't convey at all the range of goals user's might have for wanting to go to the library window.  If the user's goal is simply "I want to see the library window" I wonder if we shouldn't create a path through Tools, next to Tools > Downloads and Tools > Addons, create Tools > Library
Thanks for the understanding reply.  I've submitted minor Bug 408449 to follow-up.
From the first time I used computers, the perspective of the menus on a UI was always: "View All Bookmarks" not "See All Bookmarks".  "View" meant to go somewhere to look at them, while "See" was used, if it was every used, as a checkbox setting description that would mean something similar to "Display".
Aaggh.  I meant "Show" not "See":

From the first time I used computers, the perspective of the menus on a UI was
always: "View All Bookmarks" not "Show All Bookmarks".  "View" meant to go
somewhere to look at them, while "Show" was used, if it was every used, as a
checkbox setting description that would mean something similar to "Display".
Quote snip from above:
Yeah, I totally agree with that, but thankfully we have File > Import as a more
direct path for user's who have the goal of importing bookmarks and are in the
main window.

Currently in the latest builds the File->Import from the Main browser window only offers to Import from MS IE, no option there to 'Import from File.'

That still leaves the end-user in a situation to go 'fishing' for the correct place to import bookmarks files or to recover bookmarks.  Granted, we are all hoping that the days of 'lost bookmarks' are going to be a thing of the past, but we know that no matter what we do, someone will find a way to break it.

Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.